p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in auth0/wordpress

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für auth0/wordpress: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 5

  1. GHSA-vfpx-q664-h93m

    Hoch · CVSS 8.2Korrektur verfügbar

    Auth0 WordPress Plugin has Insufficient Entropy in Cookie Encryption

    ### Impact In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. ### Am I Affected? Consumers are affected if their application meets the following preconditions: - It is using the Auth0 WordPress Plugin, versions between 5.0.0-BETA0 and 5.5.0 - Auth0 WordPress plugin using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0. ### Resolution Upgrade Auth0/wordpress to version 5.6.0 or greater.

    • Auf 5.6.0 aktualisieren
    Veröffentlicht Aktualisiert
  2. GHSA-vvg7-8rmq-92g7

    Mittel · CVSS 6.8Korrektur verfügbar

    Auth0 WordPress has Improper Audience Validation via Auth0-PHP SDK Dependency

    ### Description In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. ### Affected product and versions Projects are affected if they meet the following preconditions: - Applications using the Auth0 Wordpress plugin with version between 5.0.0-BETA0 and 5.4.0, - Auth0 Wordpress plugin uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0. ### Resolution Upgrade Auth0 Wordpress plugin to version 5.5.0 or greater. ### Acknowledgement Okta would like to thank Jafar Sadiq (iaf4r) for their di

    • Auf 5.5.0 aktualisieren
    Veröffentlicht Aktualisiert
  3. GHSA-862m-5253-832r

    Kritisch · CVSS 9.3Korrektur verfügbar

    Auth0 Wordpress Plugin vulnerable to Deserialization of Untrusted Data

    **Overview** The Auth0 Wordpress plugin contains a critical vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. **Am I Affected?** You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0 WordPress plugin, versions between 5.0.0 BETA-0 to 5.0.1. 2. Auth0 WordPress plugin uses the Auth0-PHP SDK with version 8.0.0-BETA3 to 8.3.0. **Fix** Upgrade the Auth0 WordPress plugin to the latest version (v5.3.0).

    • Auf 5.1.0 aktualisieren
    Veröffentlicht Aktualisiert
  4. GHSA-2f4r-34m4-3w8q

    Kritisch · CVSS 9.1Korrektur verfügbar

    Auth0 Wordpress plugin Vulnerable to Brute Force Authentication Tags of CookieStore Sessions

    **Overview** Session cookies of applications using the Auth0 Wordpress plugin configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. **Am I Affected?** You are affected by this vulnerability if you meet the following pre-conditions: 1. Applications using the Auth0 WordPress Plugin with version <=5.2.1 2. Auth0 WordPress Plugin uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0. 3. Session storage configured with CookieStore. **Fix** Upgrade Auth0/wordpress plugin to v5.3.0. As an additional precautionary measure, we recommend rotating your cookie encr

    • Auf 5.3.0 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2023-6813

    Mittel · CVSS 6.1EPSS 0,36%Korrektur verfügbar

    Login by Auth0 <= 4.6.0 - Reflected Cross-Site Scripting via wle

    The Login by Auth0 plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘wle’ parameter in all versions up to, and including, 4.6.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

    • Auf 4.6.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →