p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in buddypress/buddypress

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für buddypress/buddypress: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 5

  1. CVE-2026-53675

    Mittel · CVSS 5.3EPSS 0,23%Keine Korrektur veröffentlicht

    BuddyPress 14.4.0 Friends List IDOR via REST API

    BuddyPress 14.4.0 contains an insecure direct object reference vulnerability in the friends REST API that allows any authenticated attacker to enumerate another user's complete friend list. Attackers can query the friends endpoint with an arbitrary user_id because the get_items_permissions_check method only verifies that the requester is logged in and never checks ownership of the requested list, resulting in disclosure of users' private social connections.

    Veröffentlicht Aktualisiert
  2. CVE-2026-53673

    Hoch · CVSS 8.6EPSS 0,37%Korrektur verfügbar

    BuddyPress 14.4.0 Private Message IDOR via REST API user_id Parameter

    BuddyPress 14.4.0 contains an insecure direct object reference vulnerability in the messages REST API that allows authenticated attackers to access arbitrary private message threads by supplying a user_id parameter in the request. Attackers can pass another user's identifier to the get_item_permissions_check method, which validates the supplied user_id instead of the logged-in user and is reused by the update and delete handlers, to read, reply to, or delete any user's private messages.

    • Auf 14.5.0 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2021-21389

    Hoch · CVSS 8.1EPSS 14,81%Öffentlicher ExploitKorrektur verfügbar

    BuddyPress privilege escalation via REST API

    BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

    • Auf 7.2.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →