p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in egroupware/egroupware

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für egroupware/egroupware: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 7

  1. CVE-2026-40187

    Hoch · CVSS 8.6EPSS 0,86%Korrektur verfügbar

    Authenticated RCE via Malicious eTemplate Upload in EGroupware

    In egroupware version 26.0 and earlier, an authenticated administrator can achieve OS-level Remote Code Execution (RCE) by uploading a malicious eTemplate XML file (`.xet`) to the VFS `/etemplates` mount. The `Widget::expand_name()` method passes template widget attribute values directly into a PHP `eval()` call with only double-quote escaping applied - **backtick characters are not escaped**. In PHP, backticks inside a double-quoted `eval()` string execute shell commands. This allows an admin-level user to escalate from web application access to arbitrary OS command execution on the server.

    • Auf 23.1.20260601 aktualisieren
    • Auf 26.4.20260413 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-27823

    Hoch · CVSS 8.7EPSS 0,97%Korrektur verfügbar

    Remote Code Execution Vulnerability in EGroupware

    A vulnerability has been identified in EGroupware that may lead to Remote Code Execution (RCE). The issue allows an authenticated attacker to execute arbitrary commands on the server. If user self-registration is enabled, the vulnerability may be exploitable without prior authentication. The vulnerability stems from improper authorization checks combined with a file write primitive and an arbitrary file read vulnerability, which together enable full system compromise. This has been patched in versions 26.2.20260224 and 23.1.20260224.

    • Auf 23.1.20260224 aktualisieren
    • Auf 26.2.20260224 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2026-45016

    Mittel · CVSS 6.5Korrektur verfügbar

    EGroupware Vulnerable to Local File Inclusion via file:// URI in Mail Compose

    ### Summary The function processes image URLs embedded in an HTML email body without validating or restricting URI schemes. The check `!str_starts_with($myUrl, 'http')` evaluates to true for `file://` URIs, causing `file_get_contents($basedir . urldecode($myUrl))` to read arbitrary files from the server filesystem and embed them as inline MIME attachments in outgoing email. str_starts_with('file:///etc/passwd', 'http') → **false** !false → **true** ```php // api/src/Mail.php foreach($images[2] as $i => $url) { //$isData = false; $basedir = $data = ''; $needTempFile = true; $attachmentData = ['name' => '', 'type' => '',

    • Auf 23.1.20260601 aktualisieren
    • Auf 26.5.20260507 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2026-22243

    Hoch · CVSS 8.7EPSS 0,43%Korrektur verfügbar

    EGroupware has SQL Injection in Nextmatch Filter Processing

    EGroupware is a Web based groupware server written in PHP. A SQL Injection vulnerability exists in the core components of EGroupware prior to versions 23.1.20260113 and 26.0.20260113, specifically in the `Nextmatch` filter processing. The flaw allows authenticated attackers to inject arbitrary SQL commands into the `WHERE` clause of database queries. This is achieved by exploiting a PHP type juggling issue where JSON decoding converts numeric strings into integers, bypassing the `is_int()` security check used by the application. Versions 23.1.20260113 and 26.0.20260113 patch the vulnerability.

    • Auf 23.1.20260113 aktualisieren
    • Auf 26.0.20260113 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2010-3313

    Kritisch · CVSS 9.3EPSS 8,5%Öffentlicher ExploitKorrektur verfügbar

    CVE-2010-3313

    phpgwapi/js/fckeditor/editor/dialog/fck_spellerpages/spellerpages/serverscripts/spellchecker.php in EGroupware 1.4.001+.002; 1.6.001+.002 and possibly other versions before 1.6.003; and EPL 9.1 before 9.1.20100309 and 9.2 before 9.2.20100309; allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) aspell_path or (2) spellchecker_lang parameters.

    • Auf 1.6.003 aktualisieren
    • Auf 9.1.20100309 aktualisieren
    • Auf 9.2.20100309 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →