p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in moodle/moodle · Seite 10

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für moodle/moodle: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 437

  1. CVE-2021-43560

    Mittel · CVSS 5.3EPSS 1,13%Korrektur verfügbar

    CVE-2021-43560

    A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. Insufficient capability checks made it possible to fetch other users' calendar action events.

    • Auf 3.10.8 aktualisieren
    • Auf 3.11.4 aktualisieren
    • Auf 3.9.11 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2021-43559

    Hoch · CVSS 8.8EPSS 0,62%Korrektur verfügbar

    CVE-2021-43559

    A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. The "delete related badge" functionality did not include the necessary token check to prevent a CSRF risk.

    • Auf 3.10.8 aktualisieren
    • Auf 3.11.4 aktualisieren
    • Auf 3.9.11 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2021-43558

    Mittel · CVSS 6.1EPSS 0,87%Korrektur verfügbar

    CVE-2021-43558

    A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A URL parameter in the filetype site administrator tool required extra sanitizing to prevent a reflected XSS risk.

    • Auf 3.10.8 aktualisieren
    • Auf 3.11.4 aktualisieren
    • Auf 3.9.11 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2021-3943

    Kritisch · CVSS 9.8EPSS 2,4%Korrektur verfügbar

    CVE-2021-3943

    A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A remote code execution risk when restoring backup files was identified.

    • Auf 3.10.8 aktualisieren
    • Auf 3.11.4 aktualisieren
    • Auf 3.9.11 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2021-21809

    Hoch · CVSS 8.2EPSS 24,17%Öffentlicher ExploitKeine Korrektur veröffentlicht

    CVE-2021-21809

    A command execution vulnerability exists in the default legacy spellchecker plugin in Moodle 3.10. A specially crafted series of HTTP requests can lead to command execution. An attacker must have administrator privileges to exploit this vulnerabilities.

    Veröffentlicht Aktualisiert
  6. CVE-2021-20283

    Mittel · CVSS 4.3EPSS 1,11%Korrektur verfügbar

    CVE-2021-20283

    The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

    • Auf 3.10.2 aktualisieren
    • Auf 3.5.17 aktualisieren
    • Auf 3.8.8 aktualisieren
    • Auf 3.9.5 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2021-20282

    Mittel · CVSS 5.3EPSS 1,32%Korrektur verfügbar

    CVE-2021-20282

    When creating a user account, it was possible to verify the account without having access to the verification email link/secret in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

    • Auf 3.10.2 aktualisieren
    • Auf 3.5.17 aktualisieren
    • Auf 3.8.8 aktualisieren
    • Auf 3.9.5 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2021-20281

    Mittel · CVSS 5.3EPSS 1,36%Korrektur verfügbar

    CVE-2021-20281

    It was possible for some users without permission to view other users' full names to do so via the online users block in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

    • Auf 3.10.2 aktualisieren
    • Auf 3.5.17 aktualisieren
    • Auf 3.8.8 aktualisieren
    • Auf 3.9.5 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2021-20185

    Mittel · CVSS 5.3EPSS 1,39%Korrektur verfügbar

    CVE-2021-20185

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that messaging did not impose a character limit when sending messages, which could result in client-side (browser) denial of service for users receiving very large messages.

    • Auf 3.10.1 aktualisieren
    • Auf 3.5.16 aktualisieren
    • Auf 3.8.7 aktualisieren
    • Auf 3.9.4 aktualisieren
    Veröffentlicht Aktualisiert
  10. CVE-2021-20186

    Mittel · CVSS 5.4EPSS 0,76%Korrektur verfügbar

    CVE-2021-20186

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that if the TeX notation filter was enabled, additional sanitizing of TeX content was required to prevent the risk of stored XSS.

    • Auf 3.10.1 aktualisieren
    • Auf 3.5.16 aktualisieren
    • Auf 3.8.7 aktualisieren
    • Auf 3.9.4 aktualisieren
    Veröffentlicht Aktualisiert
  11. CVE-2021-20183

    Mittel · CVSS 5.4EPSS 0,83%Korrektur verfügbar

    CVE-2021-20183

    It was found in Moodle before version 3.10.1 that some search inputs were vulnerable to reflected XSS due to insufficient escaping of search queries.

    • Auf 4.0.0-beta aktualisieren
    Veröffentlicht Aktualisiert
  12. CVE-2021-20187

    Hoch · CVSS 7.2EPSS 1,59%Korrektur verfügbar

    CVE-2021-20187

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP scripts via a PHP include used during Shibboleth authentication.

    • Auf 3.10.1 aktualisieren
    • Auf 3.5.16 aktualisieren
    • Auf 3.8.7 aktualisieren
    • Auf 3.9.4 aktualisieren
    Veröffentlicht Aktualisiert
  13. CVE-2020-25627

    Mittel · CVSS 6.1EPSS 3,72%Korrektur verfügbar

    CVE-2020-25627

    The moodlenetprofile user profile field required extra sanitizing to prevent a stored XSS risk. This affects versions 3.9 to 3.9.1. Fixed in 3.9.2.

    • Auf 3.9.2 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →