p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in silverstripe/cms

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für silverstripe/cms: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 16

  1. CVE-2026-54717

    Mittel · CVSS 5.4EPSS 0,34%Korrektur verfügbar

    Silverstripe: XSS in breadcrumbs in page list view

    Silverstripe CMS is an open source content management system. Prior to 6.2.1, page breadcrumbs in the CMS are vulnerable to cross-site scripting when viewed using the page list view, because page titles are rendered into the breadcrumb trail without being escaped. This issue is fixed in 6.2.1.

    • Auf 6.2.1 aktualisieren
    Veröffentlicht Aktualisiert
  2. GHSA-3mm9-2p44-rw39

    Hoch · CVSS 7.5Korrektur verfügbar

    Silverstripe SiteTree Creation Permission Vulnerability

    A vulnerability exists in the permission validation for SiteTree object creation. By default user permissions are not validated by the SiteTree::canCreate method, unless overridden by user code or via the configuration system. This vulnerability will allow users, or unauthenticated guests, to create new SiteTree objects in the database. This vulnerability is present when such users are given CMS access via other means, or if there is another mechanism (such as RestfulServer module) which allows model editing and relies on model-level permission checks. This vulnerability is restricted to the creation of draft or live pages, and does not all

    • Auf 3.0.12 aktualisieren
    • Auf 3.1.11 aktualisieren
    Veröffentlicht Aktualisiert
  3. GHSA-r97r-64vp-fghm

    Mittel · CVSS 6.1Korrektur verfügbar

    Silverstripe XSS vulnerability via VirtualPage

    A cross-site scripting vulnerability has been discovered in the VirtualPage class. This vulnerability can only be exploited if a user with CMS access has posted malicious or unescaped HTML into any of the textfields of a page which a VirtualPage refers to. This has been resolved by ensuring that VirtualPage safely escapes all field content.

    • Auf 3.1.10 aktualisieren
    Veröffentlicht Aktualisiert
  4. GHSA-6hh6-59j2-qrxw

    Mittel · CVSS 6.1Korrektur verfügbar

    Silverstripe History XSS Vulnerability

    A cross-site scripting vulnerability has been discovered in the CMS page history tab. This vulnerability can only be exploited if a user with CMS access has posted malicious or unescaped HTML into any of the text fields on a page, and if the "compare mode" option is selected. The HTML will be embedded into the page unescaped. This has been resolved by performing the text comparison in a HTML friendly way.

    • Auf 3.1.10 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2020-9311

    Mittel · CVSS 5.4EPSS 0,56%Keine Korrektur veröffentlicht

    CVE-2020-9311

    In SilverStripe through 4.5, malicious users with a valid Silverstripe CMS login (usually CMS access) can craft profile information which can lead to XSS for other users through specially crafted login form URLs.

    Veröffentlicht Aktualisiert
  6. CVE-2020-9309

    Hoch · CVSS 8.8EPSS 1,84%Keine Korrektur veröffentlicht

    CVE-2020-9309

    Silverstripe CMS through 4.5 can be susceptible to script execution from malicious upload contents under allowed file extensions (for example HTML code in a TXT file). When these files are stored as protected or draft files, the MIME detection can cause browsers to execute the file contents. Uploads stored as protected or draft files are allowed by default for authorised users only, but can also be enabled through custom logic as well as modules such as silverstripe/userforms. Sites using the previously optional silverstripe/mimevalidator module can configure MIME whitelists rather than extension whitelists, and hence prevent this issue. Site

    Veröffentlicht Aktualisiert
  7. CVE-2020-6164

    Hoch · CVSS 7.5EPSS 1,8%Keine Korrektur veröffentlicht

    CVE-2020-6164

    In SilverStripe through 4.5.0, a specific URL path configured by default through the silverstripe/framework module can be used to disclose the fact that a domain is hosting a Silverstripe application. There is no disclosure of the specific version. The functionality on this URL path is limited to execution in a CLI context, and is not known to present a vulnerability through web-based access. As a side-effect, this preconfigured path also blocks the creation of other resources on this path (e.g. a page).

    Veröffentlicht Aktualisiert
  8. CVE-2017-14498

    Mittel · CVSS 6.1EPSS 1,3%Korrektur verfügbar

    CVE-2017-14498

    SilverStripe CMS before 3.6.1 has XSS via an SVG document that is mishandled by (1) the Insert Media option in the content editor or (2) an admin/assets/add pathname, as demonstrated by the admin/pages/edit/EditorToolbar/MediaForm/field/AssetUploadField/upload URI, aka issue SS-2017-017.

    • Auf 3.6.1 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2015-8606

    Mittel · CVSS 6.1EPSS 1,54%Korrektur verfügbar

    CVE-2015-8606

    Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe CMS & Framework before 3.1.16 and 3.2.x before 3.2.1 allow remote attackers to inject arbitrary web script or HTML via the (1) Locale or (2) FailedLoginCount parameter to admin/security/EditForm/field/Members/item/new/ItemEditForm.

    • Auf 3.1.16 aktualisieren
    • Auf 3.2.1 aktualisieren
    Veröffentlicht Aktualisiert
  10. CVE-2011-4962

    Nicht bewertetEPSS 3,92%Korrektur verfügbar

    CVE-2011-4962

    code/sitefeatures/PageCommentInterface.php in SilverStripe 2.4.x before 2.4.6 might allow remote attackers to execute arbitrary code via a crafted cookie in a user comment submission, which is not properly handled when it is deserialized.

    • Auf 2.4.6 aktualisieren
    Veröffentlicht Aktualisiert
  11. CVE-2010-1593

    Mittel · CVSS 5.3EPSS 2,6%Korrektur verfügbar

    CVE-2010-1593

    Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe before 2.3.5 allow remote attackers to inject arbitrary web script or HTML via (1) the CommenterURL parameter to PostCommentForm, and in the Forum module before 0.2.5 in SilverStripe before 2.3.5 allow remote attackers to inject arbitrary web script or HTML via (2) the Search parameter to forums/search (aka the search script).

    • Auf 2.3.5 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →