p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in yourls/yourls

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für yourls/yourls: 1. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 9

  1. CVE-2026-62858

    Mittel · CVSS 5.3EPSS 0,47%Korrektur verfügbar

    YOURLS: Unauthenticated File Inclusion

    YOURLS is a self-hosted, customizable URL shortener written in PHP. Prior to 1.10.5, yourls_get_request() extracted the request path without sanitization, after which yourls_sanitize_url() and yourls_esc_url() preserved dot and slash traversal sequences before an attacker-controlled keyword reached file_exists() and include() under YOURLS_PAGEDIR. An unauthenticated remote attacker could traverse outside the intended pages directory and include a local PHP file that was already present on the server, such as an uploaded or injected file, causing the file to execute in the YOURLS web process. This issue is fixed in version 1.10.5.

    • Auf 1.10.5 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-63135

    Hoch · CVSS 8.2EPSS 0,43%Korrektur verfügbar

    YOURLS: Stored XSS in referrer statistics chart via crafted Referer header

    YOURLS is a self-hosted, customizable URL shortener written in PHP. From 1.5.1 until 1.10.4, YOURLS stores the HTTP Referer header through yourls_get_referrer(), yourls_sanitize_url_safe(), and yourls_log_redirect(), then aggregates the value in yourls-infos.php and passes the derived domain through yourls_get_domain(), yourls_stats_pie(), and yourls_google_array_to_data_table(). The chart builder concatenates labels into inline JavaScript without JavaScript-string escaping, so an unauthenticated attacker can poison the statistics of an existing short URL with a crafted referrer. When an administrator or public stats-page viewer opens the aff

    • Auf 1.10.4 aktualisieren
    Veröffentlicht Aktualisiert
  3. GHSA-6mp4-q625-mxjp

    Hoch · CVSS 7.1Keine Korrektur veröffentlicht

    YOURLS is vulnerable to XSS through JSONP and Callback request parameters

    ### Summary The callback and **jsonp** request parameters are directly concatenated into the response without any sanitization that allowing attackers to inject arbitrary JS code. When **YOURLS_PRIVATE** is set to **false** (public API mode), this vulnerability can be exploited by any unauthenticated attacker. In private mode, the XSS payload is still injected into the 403 response body though browser execution is blocked. ### Details Vulnerability exists in the JSONP callback handling chain: ``` yourls-api.php:127-128 if( isset( $_REQUEST['callback'] ) ) $return['callback'] = $_REQUEST['callback']; elseif ( isset( $_REQUEST['jsonp']

    Veröffentlicht Aktualisiert
  4. CVE-2020-27388

    Mittel · CVSS 5.4EPSS 0,71%Korrektur verfügbar

    CVE-2020-27388

    Multiple Stored Cross Site Scripting (XSS) vulnerabilities exist in the YOURLS Admin Panel, Versions 1.5 - 1.7.10. An authenticated user must modify a PHP plugin with a malicious payload and upload it, resulting in multiple stored XSS issues.

    • Auf 1.8 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →