p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in apache-submarine

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für apache-submarine: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 4

  1. CVE-2024-36265

    Kritisch · CVSS 9.8EPSS 0,74%Keine Korrektur veröffentlicht

    Apache Submarine Server Core: authorization bypass

    ** UNSUPPORTED WHEN ASSIGNED ** Incorrect Authorization vulnerability in Apache Submarine Server Core. This issue affects Apache Submarine Server Core: from 0.8.0. An attacker can bypass authentication by sending specially crafted REST requests. As this project is retired, we do not plan to release a version that fixes this issue. Users are recommended to find an alternative or restrict access to the instance to trusted users. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

    Veröffentlicht Aktualisiert
  2. CVE-2024-36264

    Kritisch · CVSS 9.8EPSS 1,02%Keine Korrektur veröffentlicht

    Apache Submarine Commons Utils: default secret

    ** UNSUPPORTED WHEN ASSIGNED ** Improper Authentication vulnerability in Apache Submarine Commons Utils. If the user doesn't explicitly set `submarine.auth.default.secret`, a default value will be used. This issue affects Apache Submarine Commons Utils: from 0.8.0. As this project is retired, we do not plan to release a version that fixes this issue. Users are recommended to find an alternative or restrict access to the instance to trusted users. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

    Veröffentlicht Aktualisiert
  3. CVE-2023-37924

    Kritisch · CVSS 9.8EPSS 7,22%Korrektur verfügbar

    Apache Submarine: SQL injection from unauthorized login

    Apache Software Foundation Apache Submarine has an SQL injection vulnerability when a user logs in. This issue can result in unauthorized login. Now we have fixed this issue and now user must have the correct login to access workbench. This issue affects Apache Submarine: from 0.7.0 before 0.8.0. We recommend that all submarine users with 0.7.0 upgrade to 0.8.0, which not only fixes the issue, supports the oidc authentication mode, but also removes the case of unauthenticated logins. If using the version lower than 0.8.0 and not want to upgrade, you can try cherry-pick PR https://github.com/apache/submarine/pull/1037 https://github.com/apach

    • Auf 0.8.0 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2023-46302

    Kritisch · CVSS 9.8EPSS 1,76%Korrektur verfügbar

    Apache Submarine: Fix CVE-2022-1471 SnakeYaml unsafe deserialization

    Apache Software Foundation Apache Submarine has a bug when serializing against yaml. The bug is caused by snakeyaml https://nvd.nist.gov/vuln/detail/CVE-2022-1471 . Apache Submarine uses JAXRS to define REST endpoints. In order to handle YAML requests (using application/yaml content-type), it defines a YamlEntityProvider entity provider that will process all incoming YAML requests. In order to unmarshal the request, the readFrom method is invoked, passing the entityStream containing the user-supplied data in `submarine-server/server-core/src/main/java/org/apache/submarine/server/utils/YamlUtils.java`. We have now fixed this issue in the

    • Auf 0.8.0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →