p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in dbt-core

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für dbt-core: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 4

  1. CVE-2024-40637

    Mittel · CVSS 4.2EPSS 0,37%Korrektur verfügbar

    Implicit override for built-in materializations from installed packages in dbt-core

    dbt enables data analysts and engineers to transform their data using the same practices that software engineers use to build applications. When a user installs a package in dbt, it has the ability to override macros, materializations, and other core components of dbt. This is by design, as it allows packages to extend and customize dbt's functionality. However, this also means that a malicious package could potentially override these components with harmful code. This issue has been fixed in versions 1.8.0, 1.6.14 and 1.7.14. Users are advised to upgrade. There are no kn own workarounds for this vulnerability. Users updating to either 1.6.14

    • Auf 1.6.14 aktualisieren
    • Auf 1.7.14 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2024-36105

    Mittel · CVSS 5.3EPSS 0,71%Korrektur verfügbar

    dbt allows Binding to an Unrestricted IP Address via socketsocket

    dbt enables data analysts and engineers to transform their data using the same practices that software engineers use to build applications. Prior to versions 1.6.15, 1.7.15, and 1.8.1, Binding to `INADDR_ANY (0.0.0.0)` or `IN6ADDR_ANY (::)` exposes an application on all network interfaces, increasing the risk of unauthorized access. As stated in the Python docs, a special form for address is accepted instead of a host address: `''` represents `INADDR_ANY`, equivalent to `"0.0.0.0"`. On systems with IPv6, '' represents `IN6ADDR_ANY`, which is equivalent to `"::"`. A user who serves docs on an unsecured public network, may unknowingly be hostin

    • Auf 1.6.15 aktualisieren
    • Auf 1.7.15 aktualisieren
    • Auf 1.8.1 aktualisieren
    Veröffentlicht Aktualisiert
  3. GHSA-p72q-h37j-3hq7

    Hoch · CVSS 7.5Korrektur verfügbar

    dbt uses a SQLparse version with a high vulnerability

    ### Summary Using a version of `sqlparse` that has a security vulnerability and no way to update in current version of dbt core. Snyk recommends using `sqlparse==0.5` but this causes a conflict with dbt. Snyk states the issues is a recursion error: `SNYK-PYTHON-SQLPARSE-6615674`. ### Details Dependency conflict error message: ```sh The conflict is caused by: The user requested sqlparse==0.5 dbt-core 1.7.10 depends on sqlparse<0.5 and >=0.2.3 ``` Resolution was to pin `sqlparse >=0.5.0, <0.6.0` in `dbt-core`, patched in 1.6.13 and 1.7.13. ### PoC From Snyk: ```python import sqlparse sqlparse.parse('[' * 10000 + ']' * 10000) ``` ##

    • Auf 1.6.13 aktualisieren
    • Auf 1.7.13 aktualisieren
    Veröffentlicht Aktualisiert
  4. GHSA-j4g3-3q8x-jxqp

    Niedrig · CVSS 3.2Korrektur verfügbar

    dbt-core's secret env vars written to package-lock.json in plaintext

    ### Impact When used to pull source code from a private repository using a Personal Access Token (PAT), some versions of dbt-core write a URL with the PAT in plaintext to the `package-lock.yml` file. ### Patches The bug has been fixed in [dbt-core v1.7.3](https://github.com/dbt-labs/dbt-core/releases/tag/v1.7.3). ### Mitigations Remove any git URLs with plaintext secrets from `package-lock.yml` file(s) on servers, workstations, or in source control. Rotate any tokens that have been written to version-controlled files.

    • Auf 1.7.3 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →