p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in ironic

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für ironic: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 9

  1. CVE-2026-54421

    Mittel · CVSS 6.8EPSS 0,29%Korrektur verfügbar

    CVE-2026-54421

    In OpenStack Ironic before 37.0.1, when applying a PATCH to update fields in volume properties the user is authorized for, Ironic can return unredacted sensitive information (such as iSCSI credentials). The PATCH outcome is a security issue; the POST outcome is not a security issue.

    • Auf 29.0.6 aktualisieren
    • Auf 32.0.2 aktualisieren
    • Auf 35.0.2 aktualisieren
    • Auf 37.0.1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2025-44021

    Niedrig · CVSS 2.8EPSS 0,19%Korrektur verfügbar

    CVE-2025-44021

    OpenStack Ironic before 29.0.1 can write unintended files to a target node disk during image handling (if a deployment was performed via the API). A malicious project assigned as a node owner can provide a path to any local file (readable by ironic-conductor), which may then be written to the target node disk. This is difficult to exploit in practice, because a node deployed in this manner should never reach the ACTIVE state, but it still represents a danger in environments running with non-default, insecure configurations such as with automated cleaning disabled. The fixed versions are 24.1.3, 26.1.1, and 29.0.1.

    • Auf 24.1.3 aktualisieren
    • Auf 26.1.1 aktualisieren
    • Auf 29.0.1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2024-47211

    Mittel · CVSS 5.3EPSS 0,66%Korrektur verfügbar

    CVE-2024-47211

    In OpenStack Ironic before 21.4.4, 22.x and 23.x before 23.0.3, 23.x and 24.x before 24.1.3, and 25.x and 26.x before 26.1.0, there is a lack of checksum validation of supplied image_source URLs when configured to convert images to a raw format for streaming.

    • Auf 23.0.3 aktualisieren
    • Auf 24.1.3 aktualisieren
    • Auf 26.1.1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2016-4985

    Hoch · CVSS 7.5EPSS 2,86%Korrektur verfügbar

    CVE-2016-4985

    The ironic-api service in OpenStack Ironic before 4.2.5 (Liberty) and 5.x before 5.1.2 (Mitaka) allows remote attackers to obtain sensitive information about a registered node by leveraging knowledge of the MAC address of a network card belonging to that node and sending a crafted POST request to the v1/drivers/$DRIVER_NAME/vendor_passthru resource.

    • Auf 4.2.5 aktualisieren
    • Auf 5.1.2 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →