p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

langflow 1.10.0: bekannte Sicherheitslücken

Bekannte Sicherheitslücken für langflow 1.10.0: 9. Vergleichen Sie die unten genannten Korrekturen mit Ihrer installierten Version.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 9

  1. GHSA-j8f7-x8jm-wmm4

    Mittel · CVSS 6.3Korrektur verfügbar

    Langflow: SSRF in URL-taking components (protection disabled by default / warn-only, not applied to RSS, SearXNG, Web Search, Home Assistant, Glean, Docling)

    ### Summary Before **Langflow 1.10.3**, several built-in components sent server-side HTTP requests to URLs the flow author controls, with no SSRF enforcement. An authenticated user who can build or run flows could make the Langflow server reach loopback, RFC 1918 / private networks, link-local addresses and cloud metadata endpoints (for example `http://169.254.169.254/latest/meta-data/`), and in many cases read the response back through the component output. Two things combined to cause this: 1. **Protection disabled / warn-only.** The SSRF guard (`lfx/utils/ssrf_protection.py`, added in 1.7.0 by #10544) shipped with `ssrf_protection_enabl

    • Auf 1.10.3 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2026-105741

    Hoch · CVSS 7.1EPSS 0,24%Korrektur verfügbar

    Langflow: IP Spoofing Bypass via `X-Forwarded-For` Allowing Remote Configuration Write

    Langflow is a tool for building and deploying AI-powered agents and workflows. From 1.5.0 until 1.10.3, an IP spoofing vulnerability in the Model Context Protocol (MCP) configuration installation endpoint (POST /api/v1/mcp/project/{project_id}/install) allowed authenticated remote attackers to bypass the "local-only" access restriction. By sending a spoofed X-Forwarded-For: 127.0.0.1 header, an attacker could make the server treat the request as originating from localhost, letting them write/overwrite an MCP client configuration file on the server's filesystem. This vulnerability is fixed in 1.10.3.

    • Auf 1.10.3 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2026-105698

    Mittel · CVSS 5.4EPSS 0,22%Öffentlicher ExploitKorrektur verfügbar

    Langflow: Cross-user flow access and vertex execution via deprecated /api/v1/build/{flow_id}/vertices endpoints

    Langflow is a tool for building and deploying AI-powered agents and workflows. From 1.0.0 until 1.10.1, Langflow did not verify flow ownership in the deprecated POST /api/v1/build/{flow_id}/vertices and POST /api/v1/build/{flow_id}/vertices/{vertex_id} handlers. Through version 1.7.1, an unauthenticated caller who knew another user's flow UUID could reach these handlers; from version 1.7.2 through 1.10.0, callers had to authenticate but needed no elevated privileges. Such a caller could cause retrieve_vertices_order to load and cache the private graph, enumerate its vertex identifiers, and use build_vertex to execute selected vertices and rec

    • Auf 1.10.1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2026-105697

    Kritisch · CVSS 9.9EPSS 0,79%Öffentlicher ExploitKorrektur verfügbar

    Langflow: OS command injection (RCE) via arbitrary command in MCP stdio server configuration

    Langflow is a tool for building and deploying AI-powered agents and workflows. Before Langflow 1.10.3, the MCP stdio transport launched whatever command / args a user put in an MCP server configuration, with no allowlist and (before 1.10.3) wrapped in bash -c "exec {command} ...". Any user able to reach the MCP server settings ("Settings → MCP Servers → Add MCP Server", POST/PATCH /api/v2/mcp/servers/{server_name}) or to build a flow with the MCP Tools component could add a "server" whose command is an arbitrary OS command (touch, rm -rf, a reverse shell, ...). The command runs on the Langflow host as the Langflow process user as soon as Lang

    • Auf 1.10.3 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2026-51886

    Kritisch · CVSS 9.8EPSS 0,6%Öffentlicher ExploitKorrektur verfügbar

    CVE-2026-51886

    langflow-ai langflow v1.9.3 is affected by: Code Injection. The impact is: execute arbitrary code (remote). The component is: src/backend/base/langflow/api/v1/validate.py:validate-post_validate_code-a-real-authenticated-http-post-to-api-v1. The attack vector is: Attack surface: HTTP or browser-backed service path. A public-facing route accepts raw Python source and forwards it into a server-side compile/exec validation path without any visible entitlement guard. ¶¶ A weakness has been identified in langflow-ai langflow up to 1.9.3. langflow contains a code injection vulnerability in validate-post_validate_code-a-real-authenticated-http-post-t

    • Auf 1.10.1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2026-9205

    Hoch · CVSS 7.4EPSS 0,3%Öffentlicher ExploitKorrektur verfügbar

    Langflow is affected by weaknesses in secret handling and sensitive configuration access

    IBM Langflow OSS contains a weak cryptographic key derivation vulnerability in the ensure_fernet_key() function.

    • Auf 1.10.1 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2026-7873

    Kritisch · CVSS 9.9EPSS 1,55%Öffentlicher ExploitKorrektur verfügbar

    Code Injection Vulnerability in Code Validation Endpoint

    IBM Langflow OSS 1.0.0 through 1.10.0 allows authenticated attackers to execute arbitrary OS commands and read sensitive files including credentials, enabling complete system compromise and lateral movement.

    • Auf 1.10.1.rc0 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2026-10561

    Kritisch · CVSS 10.0EPSS 0,82%Öffentlicher ExploitKorrektur verfügbar

    Unauthenticated Remote Code Execution in Langflow OSS PythonREPLComponent via Builtins Injection

    IBM Langflow OSS 1.0.0 through 1.9.3 has an vulnerability due to an improper isolation of Python execution combined with an authentication bypass that allows an unauthenticated attacker to execute arbitrary code on the host system, resulting in complete compromise

    • Auf 1.10.1 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2026-7700

    Mittel · CVSS 5.3EPSS 0,31%Öffentlicher ExploitKorrektur verfügbar

    langflow-ai langflow LambdaFilterComponent lambda_filter.py eval code injection

    A weakness has been identified in langflow-ai langflow up to 1.10.2. This affects the function eval of the file src/lfx/src/lfx/components/llm_operations/lambda_filter.py of the component LambdaFilterComponent. Executing a manipulation can lead to code injection. The attack may be performed from remote. The exploit has been made available to the public and could be used for attacks. The vendor was contacted early about this disclosure but did not respond in any way.

    • Auf 1.10.3 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →