p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in zope

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für zope: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 18

  1. CVE-2024-51734

    Hoch · CVSS 8.7EPSS 0,43%Korrektur verfügbar

    User data deletion by anoynmous users in Zope

    Zope AccessControl provides a general security framework for use in Zope. In affected versions anonymous users can delete the user data maintained by an `AccessControl.userfolder.UserFolder` which may prevent any privileged access. This problem has been fixed in version 7.2. Users are advised to upgrade. Users unable to upgrade may address the issue by adding `data__roles__ = ()` to `AccessControl.userfolder.UserFolder`.

    • Auf 5.11.1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2023-44389

    Niedrig · CVSS 3.1EPSS 0,48%Korrektur verfügbar

    Zope management interface vulnerable to stored cross site scripting via the title property

    Zope is an open-source web application server. The title property, available on most Zope objects, can be used to store script code that is executed while viewing the affected object in the Zope Management Interface (ZMI). All versions of Zope 4 and Zope 5 are affected. Patches will be released with Zope versions 4.8.11 and 5.8.6.

    • Auf 4.8.11 aktualisieren
    • Auf 5.8.6 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2023-42458

    Niedrig · CVSS 3.7EPSS 0,71%Korrektur verfügbar

    Zope vulnerable to Stored Cross Site Scripting with SVG images

    Zope is an open-source web application server. Prior to versions 4.8.10 and 5.8.5, there is a stored cross site scripting vulnerability for SVG images. Note that an image tag with an SVG image as source is never vulnerable, even when the SVG image contains malicious code. To exploit the vulnerability, an attacker would first need to upload an image, and then trick a user into following a specially crafted link. Patches are available in Zope 4.8.10 and 5.8.5. As a workaround, make sure the "Add Documents, Images, and Files" permission is only assigned to trusted roles. By default, only the Manager has this permission.

    • Auf 4.8.10 aktualisieren
    • Auf 5.8.5 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2023-41050

    Mittel · CVSS 6.8EPSS 0,64%Korrektur verfügbar

    Information disclosure through Python's "format" functionality in Zope AccessControl

    AccessControl provides a general security framework for use in Zope. Python's "format" functionality allows someone controlling the format string to "read" objects accessible (recursively) via attribute access and subscription from accessible objects. Those attribute accesses and subscriptions use Python's full blown `getattr` and `getitem`, not the policy restricted `AccessControl` variants `_getattr_` and `_getitem_`. This can lead to critical information disclosure. `AccessControl` already provides a safe variant for `str.format` and denies access to `string.Formatter`. However, `str.format_map` is still unsafe. Affected are all users who

    • Auf 4.8.9 aktualisieren
    • Auf 5.8.4 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2021-32811

    Hoch · CVSS 7.5EPSS 2,3%Korrektur verfügbar

    Remote Code Execution via Script (Python) objects under Python 3

    Zope is an open-source web application server. Zope versions prior to versions 4.6.3 and 5.3 have a remote code execution security issue. In order to be affected, one must use Python 3 for one's Zope deployment, run Zope 4 below version 4.6.3 or Zope 5 below version 5.3, and have the optional `Products.PythonScripts` add-on package installed. By default, one must have the admin-level Zope "Manager" role to add or edit Script (Python) objects through the web. Only sites that allow untrusted users to add/edit these scripts through the web are at risk. Zope releases 4.6.3 and 5.3 are not vulnerable. As a workaround, a site administrator can rest

    • Auf 4.6.3 aktualisieren
    • Auf 5.3 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2021-32807

    Mittel · CVSS 4.4EPSS 2,05%Korrektur verfügbar

    Remote Code Execution via unsafe classes in otherwise permitted modules

    The module `AccessControl` defines security policies for Python code used in restricted code within Zope applications. Restricted code is any code that resides in Zope's object database, such as the contents of `Script (Python)` objects. The policies defined in `AccessControl` severely restrict access to Python modules and only exempt a few that are deemed safe, such as Python's `string` module. However, full access to the `string` module also allows access to the class `Formatter`, which can be overridden and extended within `Script (Python)` in a way that provides access to other unsafe Python libraries. Those unsafe Python libraries can be

    • Auf 4.3 aktualisieren
    • Auf 5.2 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2021-32674

    Hoch · CVSS 8.8EPSS 1,59%Korrektur verfügbar

    Remote Code Execution via traversal in TAL expressions

    Zope is an open-source web application server. This advisory extends the previous advisory at https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36 with additional cases of TAL expression traversal vulnerabilities. Most Python modules are not available for using in TAL expressions that you can add through-the-web, for example in Zope Page Templates. This restriction avoids file system access, for example via the 'os' module. But some of the untrusted modules are available indirectly through Python modules that are available for direct use. By default, you need to have the Manager role to add or edit Zope Page Template

    • Auf 4.6.1 aktualisieren
    • Auf 5.2.1 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2021-32633

    Mittel · CVSS 6.8EPSS 1,86%Korrektur verfügbar

    Remote Code Execution via traversal in TAL expressions

    Zope is an open-source web application server. In Zope versions prior to 4.6 and 5.2, users can access untrusted modules indirectly through Python modules that are available for direct use. By default, only users with the Manager role can add or edit Zope Page Templates through the web, but sites that allow untrusted users to add/edit Zope Page Templates through the web are at risk from this vulnerability. The problem has been fixed in Zope 5.2 and 4.6. As a workaround, a site administrator can restrict adding/editing Zope Page Templates through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be ass

    • Auf 4.6 aktualisieren
    • Auf 5.2 aktualisieren
    Veröffentlicht Aktualisiert
  9. CVE-2011-4924

    Mittel · CVSS 6.1EPSS 1,36%Korrektur verfügbar

    CVE-2011-4924

    Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104

    • Auf 3.7.3 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →