SUSE-SU-2021:1954-1
SUSE-SU-2021:1954-1 · Security update for containerd, docker, runc
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.
This update for containerd, docker, runc fixes the following issues: Docker was updated to 20.10.6-ce (bsc#1184768, bsc#1182947, bsc#1181594) * Switch version to use -ce suffix rather than _ce to avoid confusing other tools (bsc#1182476). * CVE-2021-21284: Fixed a potential privilege escalation when the root user in the remapped namespace has access to the host filesystem (bsc#1181732) * CVE-2021-21285: Fixed an issue where pulling a malformed Docker image manifest crashes the dockerd daemon (bsc#1181730). * btrfs quotas being removed by Docker regularly (bsc#1183855, bsc#1175081) runc was updated to v1.0.0~rc93 (bsc#1182451, bsc#1175821 bsc#1184962). * Use the upstream runc package (bsc#1181641, bsc#1181677, bsc#1175821). * Fixed /dev/null is not available (bsc#1168481). * CVE-2021-30465: Fixed a symlink-exchange attack vulnarability (bsc#1185405). containerd was updated to v1.4.4 * CVE-2021-21334: Fixed a potential information leak through environment variables (bsc#1183397). * Handle a requirement from docker (bsc#1181594).
Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · containers
Betroffene Produkte und Versionen
containerd SUSE:Linux Enterprise Module for Containers 15 SP2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.4-5.32.1
Auf 1.4.4-5.32.1 aktualisieren
docker SUSE:Linux Enterprise Module for Containers 15 SP2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 20.10.6_ce-6.49.3
Auf 20.10.6_ce-6.49.3 aktualisieren
runc SUSE:Linux Enterprise Module for Containers 15 SP2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.0.0~rc93-1.14.2
Auf 1.0.0~rc93-1.14.2 aktualisieren
containerd SUSE:Linux Enterprise Module for Containers 15 SP3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.4-5.32.1
Auf 1.4.4-5.32.1 aktualisieren
docker SUSE:Linux Enterprise Module for Containers 15 SP3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 20.10.6_ce-6.49.3
Auf 20.10.6_ce-6.49.3 aktualisieren
runc SUSE:Linux Enterprise Module for Containers 15 SP3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.0.0~rc93-1.14.2
Auf 1.0.0~rc93-1.14.2 aktualisieren
containerd SUSE:Linux Enterprise High Performance Computing 15-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.4-5.32.1
Auf 1.4.4-5.32.1 aktualisieren
docker SUSE:Linux Enterprise High Performance Computing 15-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 20.10.6_ce-6.49.3
Auf 20.10.6_ce-6.49.3 aktualisieren
runc SUSE:Linux Enterprise High Performance Computing 15-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.0.0~rc93-1.14.2
Auf 1.0.0~rc93-1.14.2 aktualisieren
containerd SUSE:Linux Enterprise High Performance Computing 15-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.4-5.32.1
Auf 1.4.4-5.32.1 aktualisieren
docker SUSE:Linux Enterprise High Performance Computing 15-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 20.10.6_ce-6.49.3
Auf 20.10.6_ce-6.49.3 aktualisieren
runc SUSE:Linux Enterprise High Performance Computing 15-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.0.0~rc93-1.14.2
Auf 1.0.0~rc93-1.14.2 aktualisieren
containerd SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.4-5.32.1
Auf 1.4.4-5.32.1 aktualisieren
docker SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 20.10.6_ce-6.49.3
Auf 20.10.6_ce-6.49.3 aktualisieren
runc SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.0.0~rc93-1.14.2
Auf 1.0.0~rc93-1.14.2 aktualisieren
containerd SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.4-5.32.1
Auf 1.4.4-5.32.1 aktualisieren
docker SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 20.10.6_ce-6.49.3
Auf 20.10.6_ce-6.49.3 aktualisieren
runc SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.0.0~rc93-1.14.2
Auf 1.0.0~rc93-1.14.2 aktualisieren
containerd SUSE:Linux Enterprise Server 15-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.4-5.32.1
Auf 1.4.4-5.32.1 aktualisieren
docker SUSE:Linux Enterprise Server 15-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 20.10.6_ce-6.49.3
Auf 20.10.6_ce-6.49.3 aktualisieren
runc SUSE:Linux Enterprise Server 15-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.0.0~rc93-1.14.2
Auf 1.0.0~rc93-1.14.2 aktualisieren
containerd SUSE:Linux Enterprise Server 15 SP1-BCL
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.4-5.32.1
Auf 1.4.4-5.32.1 aktualisieren
docker SUSE:Linux Enterprise Server 15 SP1-BCL
- Betroffene Versionsbereiche
- ECOSYSTEM: < 20.10.6_ce-6.49.3
Auf 20.10.6_ce-6.49.3 aktualisieren
runc SUSE:Linux Enterprise Server 15 SP1-BCL
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.0.0~rc93-1.14.2
Auf 1.0.0~rc93-1.14.2 aktualisieren
Originalquellen
- https://www.suse.com/support/update/announcement/2021/suse-su-20211954-1/
- https://bugzilla.suse.com/1168481
- https://bugzilla.suse.com/1175081
- https://bugzilla.suse.com/1175821
- https://bugzilla.suse.com/1181594
- https://bugzilla.suse.com/1181641
- https://bugzilla.suse.com/1181677
- https://bugzilla.suse.com/1181730
- https://bugzilla.suse.com/1181732
- https://bugzilla.suse.com/1181749
- https://bugzilla.suse.com/1182451
- https://bugzilla.suse.com/1182476
- https://bugzilla.suse.com/1182947
- https://bugzilla.suse.com/1183024
- https://bugzilla.suse.com/1183855
- https://bugzilla.suse.com/1184768
- https://bugzilla.suse.com/1184962
- https://bugzilla.suse.com/1185405
- https://www.suse.com/security/cve/CVE-2021-21284
- https://www.suse.com/security/cve/CVE-2021-21285
- https://www.suse.com/security/cve/CVE-2021-21334
- https://www.suse.com/security/cve/CVE-2021-30465
- https://osv.dev/vulnerability/SUSE-SU-2021:1954-1