p PatchFirst

SUSE-SU-2022:3997-1

SUSE-SU-2022:3997-1 · Security update for php7

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

This update for php7 fixes the following issues: - Version update to 7.4.33: - CVE-2022-31630: Fixed out-of-bounds read due to insufficient input validation in imageloadfont() (bsc#1204979). - CVE-2022-37454: Fixed buffer overflow in hash_update() on long parameter (bsc#1204577). - Version update to 7.4.32 (jsc#SLE-23639) - CVE-2022-31628: Fixed an uncontrolled recursion in the phar uncompressor while decompressing 'quines' gzip files. (bsc#1203867) - CVE-2022-31629: Fixed a bug which could lead an attacker to set an insecure cookie that will treated as secure in the victim's browser. (bsc#1203870)

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • apache2-mod_php7 SUSE:Linux Enterprise Module for Legacy 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.4.33-150400.4.13.1

    Auf 7.4.33-150400.4.13.1 aktualisieren

  • php7 SUSE:Linux Enterprise Module for Legacy 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.4.33-150400.4.13.1

    Auf 7.4.33-150400.4.13.1 aktualisieren

  • php7-fastcgi SUSE:Linux Enterprise Module for Legacy 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.4.33-150400.4.13.1

    Auf 7.4.33-150400.4.13.1 aktualisieren

  • php7-fpm SUSE:Linux Enterprise Module for Legacy 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.4.33-150400.4.13.1

    Auf 7.4.33-150400.4.13.1 aktualisieren

  • php7-embed SUSE:Linux Enterprise Module for Package Hub 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.4.33-150400.4.13.1

    Auf 7.4.33-150400.4.13.1 aktualisieren

  • apache2-mod_php7 openSUSE:Leap 15.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.4.33-150400.4.13.1

    Auf 7.4.33-150400.4.13.1 aktualisieren

  • php7 openSUSE:Leap 15.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.4.33-150400.4.13.1

    Auf 7.4.33-150400.4.13.1 aktualisieren

  • php7-embed openSUSE:Leap 15.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.4.33-150400.4.13.1

    Auf 7.4.33-150400.4.13.1 aktualisieren

  • php7-fastcgi openSUSE:Leap 15.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.4.33-150400.4.13.1

    Auf 7.4.33-150400.4.13.1 aktualisieren

  • php7-fpm openSUSE:Leap 15.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.4.33-150400.4.13.1

    Auf 7.4.33-150400.4.13.1 aktualisieren

  • php7-test openSUSE:Leap 15.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.4.33-150400.4.13.2

    Auf 7.4.33-150400.4.13.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →