SUSE-SU-2023:0074-1
SUSE-SU-2023:0074-1 · Security update for php8
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
This update for php8 fixes the following issues: - Updated to version 8.0.27: - CVE-2022-31631: Fixed an issue where PDO::quote would return an unquoted string (bsc#1206958). Non-security fixes: - Fixed a NULL pointer dereference with -w/-s options. - Fixed a crash in Generator when interrupted during argument evaluation with extra named params. - Fixed a crash in Generator when memory limit was exceeded during initialization. - Fixed a memory leak in Generator when interrupted during argument evaluation. - Fixed an issue in the DateTimeZone constructor where an extra null byte could be added to the input. - Fixed a hang in SaltStack when using php-fpm 8.1.11. - Fixed mysqli_query warnings being shown despite using silenced error mode. - Fixed a NULL pointer dereference when serializing a SOAP response call.
Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
apache2-mod_php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.27-150400.4.23.1
Auf 8.0.27-150400.4.23.1 aktualisieren
php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.27-150400.4.23.1
Auf 8.0.27-150400.4.23.1 aktualisieren
php8-embed SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.27-150400.4.23.1
Auf 8.0.27-150400.4.23.1 aktualisieren
php8-fastcgi SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.27-150400.4.23.1
Auf 8.0.27-150400.4.23.1 aktualisieren
php8-fpm SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.27-150400.4.23.1
Auf 8.0.27-150400.4.23.1 aktualisieren
php8-test SUSE:Linux Enterprise Module for Web and Scripting 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.27-150400.4.23.1
Auf 8.0.27-150400.4.23.1 aktualisieren
apache2-mod_php8 openSUSE:Leap 15.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.27-150400.4.23.1
Auf 8.0.27-150400.4.23.1 aktualisieren
php8 openSUSE:Leap 15.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.27-150400.4.23.1
Auf 8.0.27-150400.4.23.1 aktualisieren
php8-embed openSUSE:Leap 15.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.27-150400.4.23.1
Auf 8.0.27-150400.4.23.1 aktualisieren
php8-fastcgi openSUSE:Leap 15.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.27-150400.4.23.1
Auf 8.0.27-150400.4.23.1 aktualisieren
php8-fpm openSUSE:Leap 15.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.27-150400.4.23.1
Auf 8.0.27-150400.4.23.1 aktualisieren
php8-test openSUSE:Leap 15.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.27-150400.4.23.1
Auf 8.0.27-150400.4.23.1 aktualisieren