SUSE-SU-2023:3419-1
SUSE-SU-2023:3419-1 · Security update for webkit2gtk3
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
This update for webkit2gtk3 fixes the following issues: Update to version 2.40.5 (bsc#1213905): - CVE-2023-38133: Fixed information disclosure. - CVE-2023-38572: Fixed Same-Origin-Policy bypass. - CVE-2023-38592: Fixed arbitrary code execution. - CVE-2023-38594: Fixed arbitrary code execution. - CVE-2023-38595: Fixed arbitrary code execution. - CVE-2023-38597: Fixed arbitrary code execution. - CVE-2023-38599: Fixed sensitive user information tracking. - CVE-2023-38600: Fixed arbitrary code execution. - CVE-2023-38611: Fixed arbitrary code execution. Update to version 2.40.3 (bsc#1212863): - CVE-2023-32439: Fixed a bug where processing maliciously crafted web content may lead to arbitrary code execution. (bsc#1212863) - CVE-2023-32435: Fixed a bug where processing web content may lead to arbitrary code execution. (bsc#1212863) - CVE-2022-48503: Fixed a bug where processing web content may lead to arbitrary code execution. (bsc#1212863)
Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.40.5-150400.4.45.3
Auf 2.40.5-150400.4.45.3 aktualisieren
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.40.5-150400.4.45.3
Auf 2.40.5-150400.4.45.3 aktualisieren
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.40.5-150400.4.45.3
Auf 2.40.5-150400.4.45.3 aktualisieren
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.40.5-150400.4.45.3
Auf 2.40.5-150400.4.45.3 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.40.5-150400.4.45.3
Auf 2.40.5-150400.4.45.3 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.40.5-150400.4.45.3
Auf 2.40.5-150400.4.45.3 aktualisieren
webkit2gtk3 openSUSE:Leap 15.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.40.5-150400.4.45.3
Auf 2.40.5-150400.4.45.3 aktualisieren
webkit2gtk3-soup2 openSUSE:Leap 15.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.40.5-150400.4.45.3
Auf 2.40.5-150400.4.45.3 aktualisieren
webkit2gtk4 openSUSE:Leap 15.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.40.5-150400.4.45.3
Auf 2.40.5-150400.4.45.3 aktualisieren
webkit2gtk3 openSUSE:Leap 15.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.40.5-150400.4.45.3
Auf 2.40.5-150400.4.45.3 aktualisieren
webkit2gtk3-soup2 openSUSE:Leap 15.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.40.5-150400.4.45.3
Auf 2.40.5-150400.4.45.3 aktualisieren
webkit2gtk4 openSUSE:Leap 15.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.40.5-150400.4.45.3
Auf 2.40.5-150400.4.45.3 aktualisieren
Originalquellen
- https://www.suse.com/support/update/announcement/2023/suse-su-20233419-1/
- https://bugzilla.suse.com/1212863
- https://bugzilla.suse.com/1213905
- https://www.suse.com/security/cve/CVE-2022-48503
- https://www.suse.com/security/cve/CVE-2023-32435
- https://www.suse.com/security/cve/CVE-2023-32439
- https://www.suse.com/security/cve/CVE-2023-38133
- https://www.suse.com/security/cve/CVE-2023-38572
- https://www.suse.com/security/cve/CVE-2023-38592
- https://www.suse.com/security/cve/CVE-2023-38594
- https://www.suse.com/security/cve/CVE-2023-38595
- https://www.suse.com/security/cve/CVE-2023-38597
- https://www.suse.com/security/cve/CVE-2023-38599
- https://www.suse.com/security/cve/CVE-2023-38600
- https://www.suse.com/security/cve/CVE-2023-38611
- https://osv.dev/vulnerability/SUSE-SU-2023:3419-1