p PatchFirst

SUSE-SU-2023:3753-1

SUSE-SU-2023:3753-1 · Security update for webkit2gtk3

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

This update for webkit2gtk3 fixes the following issues: - Expand lang sub-package in spec file unconditionally to handle previous name change from WebKit2GTK-lang to WebKitGTK-lang. This change affected the automatic generated Requires tag on WebKit2GTK-%{_apiver}, then getting out of sync of what's being required and what's being provided. Now, any sub-package that was providing WebKit2GTK-%{_apiver} will provide WebKitGTK-%{_apiver} instead (bsc#1214835, bsc#1214640, bsc#1214093). - Require libwaylandclient0 >= 1.20. 15.4 originally had 1.19.0, but webkitgtk uses a function added in 1.20.0, so we need to ensure that the wayland update is pulled in (bsc#1215072). - Update to version 2.40.5 (bsc#1213905 bsc#1213379 bsc#1213581 bsc#1215230): CVE-2023-38594, CVE-2023-38595, CVE-2023-38597, CVE-2023-38599, CVE-2023-38600, CVE-2023-38611, CVE-2023-40397, CVE-2023-37450, CVE-2023-28198, CVE-2023-32370

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.40.5-150400.4.51.1

    Auf 2.40.5-150400.4.51.1 aktualisieren

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.40.5-150400.4.51.1

    Auf 2.40.5-150400.4.51.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.40.5-150400.4.51.1

    Auf 2.40.5-150400.4.51.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.40.5-150400.4.51.1

    Auf 2.40.5-150400.4.51.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.40.5-150400.4.51.1

    Auf 2.40.5-150400.4.51.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.40.5-150400.4.51.1

    Auf 2.40.5-150400.4.51.1 aktualisieren

  • webkit2gtk3 openSUSE:Leap 15.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.40.5-150400.4.51.1

    Auf 2.40.5-150400.4.51.1 aktualisieren

  • webkit2gtk3-soup2 openSUSE:Leap 15.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.40.5-150400.4.51.1

    Auf 2.40.5-150400.4.51.1 aktualisieren

  • webkit2gtk4 openSUSE:Leap 15.4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.40.5-150400.4.51.1

    Auf 2.40.5-150400.4.51.1 aktualisieren

  • webkit2gtk3 openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.40.5-150400.4.51.1

    Auf 2.40.5-150400.4.51.1 aktualisieren

  • webkit2gtk3-soup2 openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.40.5-150400.4.51.1

    Auf 2.40.5-150400.4.51.1 aktualisieren

  • webkit2gtk4 openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.40.5-150400.4.51.1

    Auf 2.40.5-150400.4.51.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →