p PatchFirst

SUSE-SU-2024:0519-1

SUSE-SU-2024:0519-1 · Security update for webkit2gtk3

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

This update for webkit2gtk3 fixes the following issues: Update to version 2.42.5 (bsc#1219604): - CVE-2024-23222: Fixed processing maliciously crafted web content that may have led to arbitrary code execution (bsc#1219113). - CVE-2024-23206: Fixed fingerprint user via maliciously crafted webpages (bsc#1219604). - CVE-2024-23213: Fixed processing web content that may have led to arbitrary code execution (bsc#1219604). - CVE-2023-40414: Fixed processing web content that may have led to arbitrary code execution (bsc#1219604). - CVE-2014-1745: Fixed denial-of-service or potentially disclose memory contents while processing maliciously crafted files (bsc#1219604). - CVE-2023-42833: Fixed processing web content that may have led to arbitrary code execution (bsc#1219604).

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.5-150200.104.1

    Auf 2.42.5-150200.104.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.5-150200.104.1

    Auf 2.42.5-150200.104.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP2-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.5-150200.104.1

    Auf 2.42.5-150200.104.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP3-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.5-150200.104.1

    Auf 2.42.5-150200.104.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP2

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.5-150200.104.1

    Auf 2.42.5-150200.104.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP3

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.5-150200.104.1

    Auf 2.42.5-150200.104.1 aktualisieren

  • webkit2gtk3 SUSE:Enterprise Storage 7.1

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.42.5-150200.104.1

    Auf 2.42.5-150200.104.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →