SUSE-SU-2024:0548-1
SUSE-SU-2024:0548-1 · Security update for webkit2gtk3
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
This update for webkit2gtk3 fixes the following issues: Update to version 2.42.5 (bsc#1219604): - CVE-2024-23222: Fixed processing maliciously crafted web content that may have led to arbitrary code execution (bsc#1219113). - CVE-2024-23206: Fixed fingerprint user via maliciously crafted webpages (bsc#1219604). - CVE-2024-23213: Fixed processing web content that may have led to arbitrary code execution (bsc#1219604). - CVE-2023-40414: Fixed processing web content that may have led to arbitrary code execution (bsc#1219604). - CVE-2014-1745: Fixed denial-of-service or potentially disclose memory contents while processing maliciously crafted files (bsc#1219604). - CVE-2023-42833: Fixed processing web content that may have led to arbitrary code execution (bsc#1219604).
Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk3-soup2 SUSE:Manager Proxy 4.3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk3-soup2 SUSE:Manager Server 4.3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk3 openSUSE:Leap 15.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk3-soup2 openSUSE:Leap 15.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
webkit2gtk4 openSUSE:Leap 15.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.42.5-150400.4.75.1
Auf 2.42.5-150400.4.75.1 aktualisieren
Originalquellen
- https://www.suse.com/support/update/announcement/2024/suse-su-20240548-1/
- https://bugzilla.suse.com/1219113
- https://bugzilla.suse.com/1219604
- https://www.suse.com/security/cve/CVE-2014-1745
- https://www.suse.com/security/cve/CVE-2023-40414
- https://www.suse.com/security/cve/CVE-2023-42833
- https://www.suse.com/security/cve/CVE-2024-23206
- https://www.suse.com/security/cve/CVE-2024-23213
- https://www.suse.com/security/cve/CVE-2024-23222
- https://osv.dev/vulnerability/SUSE-SU-2024:0548-1