p PatchFirst

SUSE-SU-2024:3109-1

SUSE-SU-2024:3109-1 · Security update for webkit2gtk3

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

This update for webkit2gtk3 fixes the following issues: Update to version 2.44.3 (bsc#1228696 bsc#1228697 bsc#1228698): - Fix web process cache suspend/resume when sandbox is enabled. - Fix accelerated images dissapearing after scrolling. - Fix video flickering with DMA-BUF sink. - Fix pointer lock on X11. - Fix movement delta on mouse events in GTK3. - Undeprecate console message API and make it available in 2022 API. - Fix several crashes and rendering issues. - Security fixes: CVE-2024-40776, CVE-2024-40779, CVE-2024-40780, CVE-2024-40782, CVE-2024-40785, CVE-2024-40789, CVE-2024-40794, CVE-2024-4558.

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.3-150600.12.9.1

    Auf 2.44.3-150600.12.9.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Module for Basesystem 15 SP6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.3-150600.12.9.1

    Auf 2.44.3-150600.12.9.1 aktualisieren

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.3-150600.12.9.1

    Auf 2.44.3-150600.12.9.1 aktualisieren

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.3-150600.12.9.1

    Auf 2.44.3-150600.12.9.1 aktualisieren

  • webkit2gtk3 openSUSE:Leap 15.6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.3-150600.12.9.1

    Auf 2.44.3-150600.12.9.1 aktualisieren

  • webkit2gtk3-soup2 openSUSE:Leap 15.6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.3-150600.12.9.1

    Auf 2.44.3-150600.12.9.1 aktualisieren

  • webkit2gtk4 openSUSE:Leap 15.6

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.44.3-150600.12.9.1

    Auf 2.44.3-150600.12.9.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →