p PatchFirst

SUSE-SU-2024:3418-1

SUSE-SU-2024:3418-1 · Security update for python311

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

This update for python311 fixes the following issues: - Update python311 to version 3.11.10. - CVE-2024-6232: excessive backtracking when parsing tarfile headers leads to ReDoS. (bsc#1230227) - CVE-2024-7592: quadratic algorithm used when parsing cookies leads to excessive resource consumption. (bsc#1229596) - CVE-2024-8088: lack of name validation when extracting a zip archive leads to infinite loops. (bsc#1229704)

Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • python311 SUSE:Linux Enterprise Module for Public Cloud 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311-core SUSE:Linux Enterprise Module for Public Cloud 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311 SUSE:Linux Enterprise Module for Python 3 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311-core SUSE:Linux Enterprise Module for Python 3 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311-documentation SUSE:Linux Enterprise Module for Python 3 15 SP5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311-core SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311-documentation SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311-core SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311-documentation SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311-core SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311-documentation SUSE:Linux Enterprise Server 15 SP4-LTSS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311-core SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311-documentation SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311 openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311-core openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

  • python311-documentation openSUSE:Leap 15.5

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.10-150400.9.35.1

    Auf 3.11.10-150400.9.35.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →