SUSE-SU-2025:02462-1
SUSE-SU-2025:02462-1 · Security update for php8
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
This update for php8 fixes the following issues: Version update to 8.3.23: - CVE-2025-1220: Fixed null byte termination in hostnames (bsc#1246167) - CVE-2025-1735: Fixed pgsql extension does not check for errors during escaping (bsc#1246146) - CVE-2025-6491: Fixed NULL Pointer Dereference in PHP SOAP Extension via Large XML Namespace Prefix (bsc#1246148)
Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
apache2-mod_php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.3.23-150700.3.3.1
Auf 8.3.23-150700.3.3.1 aktualisieren
php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.3.23-150700.3.3.1
Auf 8.3.23-150700.3.3.1 aktualisieren
php8-embed SUSE:Linux Enterprise Module for Web and Scripting 15 SP7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.3.23-150700.3.3.1
Auf 8.3.23-150700.3.3.1 aktualisieren
php8-fastcgi SUSE:Linux Enterprise Module for Web and Scripting 15 SP7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.3.23-150700.3.3.1
Auf 8.3.23-150700.3.3.1 aktualisieren
php8-fpm SUSE:Linux Enterprise Module for Web and Scripting 15 SP7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.3.23-150700.3.3.1
Auf 8.3.23-150700.3.3.1 aktualisieren
php8-test SUSE:Linux Enterprise Module for Web and Scripting 15 SP7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.3.23-150700.3.3.2
Auf 8.3.23-150700.3.3.2 aktualisieren
Originalquellen
- https://www.suse.com/support/update/announcement/2025/suse-su-202502462-1/
- https://bugzilla.suse.com/1246146
- https://bugzilla.suse.com/1246148
- https://bugzilla.suse.com/1246167
- https://www.suse.com/security/cve/CVE-2025-1220
- https://www.suse.com/security/cve/CVE-2025-1735
- https://www.suse.com/security/cve/CVE-2025-6491
- https://osv.dev/vulnerability/SUSE-SU-2025:02462-1