SUSE-SU-2025:4190-1
SUSE-SU-2025:4190-1 · Security update for helm
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
This update for helm fixes the following issues: - Update to version 3.19.1 - CVE-2025-53547: Fixed local code execution in Helm Chart. (bsc#1246152) - CVE-2025-58190: Fixed excessive memory consumption by `html.ParseFragment` when processing specially crafted input. (bsc#1251649) - CVE-2025-47911: Fixed various algorithms with quadratic complexity when parsing HTML documents. (bsc#1251442)
Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
helm SUSE:Linux Enterprise Micro 5.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise Module for Containers 15 SP6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise Module for Containers 15 SP7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise Module for Package Hub 15 SP6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise Module for Package Hub 15 SP7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise Server 15 SP3-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise Server 15 SP4-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise Server 15 SP5-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise Server for SAP Applications 15 SP3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm SUSE:Enterprise Storage 7.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
helm openSUSE:Leap 15.6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.19.1-150000.1.57.1
Auf 3.19.1-150000.1.57.1 aktualisieren
Originalquellen
- https://www.suse.com/support/update/announcement/2025/suse-su-20254190-1/
- https://bugzilla.suse.com/1246152
- https://bugzilla.suse.com/1251442
- https://bugzilla.suse.com/1251649
- https://www.suse.com/security/cve/CVE-2025-47911
- https://www.suse.com/security/cve/CVE-2025-53547
- https://www.suse.com/security/cve/CVE-2025-58190
- https://osv.dev/vulnerability/SUSE-SU-2025:4190-1