SUSE-SU-2025:4527-1
SUSE-SU-2025:4527-1 · Security update for webkit2gtk3
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.
This update for webkit2gtk3 fixes the following issues: Update to version 2.50.4. Security issues fixed: - CVE-2025-14174: processing maliciously crafted web content may lead to memory corruption due to improper validation (bsc#1255497). - CVE-2025-43501: processing maliciously crafted web content may lead to an unexpected process crash due to a buffer overflow issue (bsc#1255194). - CVE-2025-43529: processing maliciously crafted web content may lead to arbitrary code execution due to a use-after-free issue (bsc#1255198). - CVE-2025-43531: processing maliciously crafted web content may lead to an unexpected process crash due to a race condition (bsc#1255183). - CVE-2025-43535: processing maliciously crafted web content may lead to an unexpected process crash due to improper memory handling (bsc#1255195). - CVE-2025-43536: processing maliciously crafted web content may lead to an unexpected process crash due to a use-after-free issue (bsc#1255200). - CVE-2025-43541: processing maliciously crafted web content may lead to an unexpected process crash due to type confusion (bsc#1255191). Other updates and bugfixes: - Version 2.50.4: * Correctly handle the program name passed to the sleep disabler. * Ensure GStreamer is initialized before using the Quirks. * Fix several crashes and rendering issues. - Fix a11y regression where AT-SPI roles were mapped incorrectly.
Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.1
Auf 2.50.4-150400.4.134.1 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.1
Auf 2.50.4-150400.4.134.1 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.1
Auf 2.50.4-150400.4.134.1 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.1
Auf 2.50.4-150400.4.134.1 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.1
Auf 2.50.4-150400.4.134.1 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise Server 15 SP4-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.1
Auf 2.50.4-150400.4.134.1 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise Server 15 SP5-LTSS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.1
Auf 2.50.4-150400.4.134.1 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.1
Auf 2.50.4-150400.4.134.1 aktualisieren
webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.50.4-150400.4.134.2
Auf 2.50.4-150400.4.134.2 aktualisieren
Originalquellen
- https://www.suse.com/support/update/announcement/2025/suse-su-20254527-1/
- https://bugzilla.suse.com/1255183
- https://bugzilla.suse.com/1255191
- https://bugzilla.suse.com/1255194
- https://bugzilla.suse.com/1255195
- https://bugzilla.suse.com/1255198
- https://bugzilla.suse.com/1255200
- https://bugzilla.suse.com/1255497
- https://www.suse.com/security/cve/CVE-2025-14174
- https://www.suse.com/security/cve/CVE-2025-43501
- https://www.suse.com/security/cve/CVE-2025-43529
- https://www.suse.com/security/cve/CVE-2025-43531
- https://www.suse.com/security/cve/CVE-2025-43535
- https://www.suse.com/security/cve/CVE-2025-43536
- https://www.suse.com/security/cve/CVE-2025-43541
- https://osv.dev/vulnerability/SUSE-SU-2025:4527-1