p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in trafficserver · Seite 6

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für trafficserver: 16. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 114

  1. CVE-2019-9515

    Hoch · CVSS 7.5EPSS 87,29%Keine Korrektur veröffentlicht

    Some HTTP/2 implementations are vulnerable to a settings flood, potentially leading to a denial of service

    Some HTTP/2 implementations are vulnerable to a settings flood, potentially leading to a denial of service. The attacker sends a stream of SETTINGS frames to the peer. Since the RFC requires that the peer reply with one acknowledgement per SETTINGS frame, an empty SETTINGS frame is almost equivalent in behavior to a ping. Depending on how efficiently this data is queued, this can consume excess CPU, memory, or both.

    Veröffentlicht Aktualisiert
  2. CVE-2019-9512

    Hoch · CVSS 7.5EPSS 83,43%Keine Korrektur veröffentlicht

    Some HTTP/2 implementations are vulnerable to ping floods, potentially leading to a denial of service

    Some HTTP/2 implementations are vulnerable to ping floods, potentially leading to a denial of service. The attacker sends continual pings to an HTTP/2 peer, causing the peer to build an internal queue of responses. Depending on how efficiently this data is queued, this can consume excess CPU, memory, or both.

    Veröffentlicht Aktualisiert
  3. CVE-2019-9514

    Hoch · CVSS 7.5EPSS 82,81%Keine Korrektur veröffentlicht

    Some HTTP/2 implementations are vulnerable to a reset flood, potentially leading to a denial of service

    Some HTTP/2 implementations are vulnerable to a reset flood, potentially leading to a denial of service. The attacker opens a number of streams and sends an invalid request over each stream that should solicit a stream of RST_STREAM frames from the peer. Depending on how the peer queues the RST_STREAM frames, this can consume excess memory, CPU, or both.

    Veröffentlicht Aktualisiert
  4. CVE-2018-11783

    Hoch · CVSS 7.5EPSS 1,87%Keine Korrektur veröffentlicht

    CVE-2018-11783

    sslheaders plugin extracts information from the client certificate and sets headers in the request based on the configuration of the plugin. The plugin doesn't strip the headers from the request in some scenarios. This problem was discovered in versions 6.0.0 to 6.0.3, 7.0.0 to 7.1.5, and 8.0.0 to 8.0.1.

    Veröffentlicht Aktualisiert
  5. CVE-2018-8040

    Mittel · CVSS 5.3EPSS 7,17%Keine Korrektur veröffentlicht

    CVE-2018-8040

    Pages that are rendered using the ESI plugin can have access to the cookie header when the plugin is configured not to allow access. This affects Apache Traffic Server (ATS) versions 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.

    Veröffentlicht Aktualisiert
  6. CVE-2018-8005

    Mittel · CVSS 5.3EPSS 6,89%Keine Korrektur veröffentlicht

    CVE-2018-8005

    When there are multiple ranges in a range request, Apache Traffic Server (ATS) will read the entire object from cache. This can cause performance problems with large objects in cache. This affects versions 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x users should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.

    Veröffentlicht Aktualisiert
  7. CVE-2018-8004

    Mittel · CVSS 6.5EPSS 6,31%Keine Korrektur veröffentlicht

    CVE-2018-8004

    There are multiple HTTP smuggling and cache poisoning issues when clients making malicious requests interact with Apache Traffic Server (ATS). This affects versions 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.

    Veröffentlicht Aktualisiert
  8. CVE-2018-1318

    Hoch · CVSS 7.5EPSS 7,72%Keine Korrektur veröffentlicht

    CVE-2018-1318

    Adding method ACLs in remap.config can cause a segfault when the user makes a carefully crafted request. This affects versions Apache Traffic Server (ATS) 6.0.0 to 6.2.2 and 7.0.0 to 7.1.3. To resolve this issue users running 6.x should upgrade to 6.2.3 or later versions and 7.x users should upgrade to 7.1.4 or later versions.

    Veröffentlicht Aktualisiert
  9. CVE-2015-3249

    Kritisch · CVSS 9.8EPSS 5,44%Keine Korrektur veröffentlicht

    CVE-2015-3249

    The HTTP/2 experimental feature in Apache Traffic Server 5.3.x before 5.3.1 allows remote attackers to cause a denial of service (out-of-bounds access and daemon crash) or possibly execute arbitrary code via vectors related to the (1) frame_handlers array or (2) set_dynamic_table_size function.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →