p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in ruby-thrift

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für ruby-thrift: 3. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 4

  1. CVE-2026-96277

    Hoch · CVSS 8.7EPSS 0,34%Keine Korrektur veröffentlicht

    Apache Thrift: Ruby `SimpleServer` ends `serve()` on any non-Transport/Protocol exception

    Uncaught exception, Improper Handling of Exceptional Conditions vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  2. CVE-2026-94656

    Hoch · CVSS 8.2EPSS 0,34%Keine Korrektur veröffentlicht

    Apache Thrift: rb `TJsonProtocol`/`TJSONProtocol` has no string size bound

    Allocation of resources without limits or throttling vulnerability in Apache Thrift ruby bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  3. CVE-2026-85494

    Hoch · CVSS 8.7EPSS 0,31%Keine Korrektur veröffentlicht

    Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: Framed transport and binary protocol size read buffers from a peer-declared length without a limit (multi-language)

    Improper handling of length parameter inconsistency, Uncaught exception, Inefficient Algorithmic Complexity, Memory allocation with excessive size value, Initialization of a resource with an insecure default vulnerability in Apache Thrift Python, Ruby, Erlang, Lua, Dart, JavaME, Perl, PHP and D language bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

    Veröffentlicht Aktualisiert
  4. CVE-2026-49158

    Hoch · CVSS 7.5EPSS 1,03%Keine Korrektur veröffentlicht

    Apache Thrift: Ruby THeaderTransport ZLIB Decompression Bomb

    Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →