p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in setuptools

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für setuptools: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 4

  1. CVE-2026-59890

    Mittel · CVSS 6.1EPSS 0,4%Keine Korrektur veröffentlicht

    setuptools: MANIFEST.in exclusion bypass in sdist via Unicode normalization collision (NFC/NFD) on macOS APFS/HFS+

    setuptools is a package that allows users to download, build, install, upgrade, and uninstall Python packages. Prior to 83.0.0, FileList applied MANIFEST.in exclude, global-exclude, recursive-exclude, and prune directives by matching compiled glob patterns against on-disk file names without Unicode normalization, so on macOS APFS or HFS+ an NFD file name could bypass an NFC exclusion rule and be packed into a source distribution. This issue is fixed in version 83.0.0.

    Veröffentlicht Aktualisiert
  2. CVE-2025-47273

    Hoch · CVSS 7.7EPSS 1,59%Korrektur verfügbar

    setuptools has a path traversal vulnerability in PackageIndex.download that leads to Arbitrary File Write

    setuptools is a package that allows users to download, build, install, upgrade, and uninstall Python packages. A path traversal vulnerability in `PackageIndex` is present in setuptools prior to version 78.1.1. An attacker would be allowed to write files to arbitrary locations on the filesystem with the permissions of the process running the Python code, which could escalate to remote code execution depending on the context. Version 78.1.1 fixes the issue.

    • Auf 59.6.0-1.2ubuntu0.22.04.3 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2024-6345

    Hoch · CVSS 8.8EPSS 1,94%Korrektur verfügbar

    Remote Code Execution in pypa/setuptools

    A vulnerability in the package_index module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.

    • Auf 59.6.0-1.2ubuntu0.22.04.2 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2022-40897

    Mittel · CVSS 5.9EPSS 2,63%Korrektur verfügbar

    CVE-2022-40897

    Python Packaging Authority (PyPA) setuptools before 65.5.1 allows remote attackers to cause a denial of service via HTML in a crafted package or custom PackageIndex page. There is a Regular Expression Denial of Service (ReDoS) in package_index.py.

    • Auf 59.6.0-1.2ubuntu0.22.04.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →