p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in node-markdown-it

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für node-markdown-it: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 5

  1. CVE-2026-48988

    Mittel · CVSS 5.3EPSS 0,38%Keine Korrektur veröffentlicht

    markdown-it: Quadratic complexity DoS in smartquotes rule via replaceAt string operations

    markdown-it is a Markdown parser. Versions 14.1.1 and below contain a denial-of-service vulnerability when typographer: true is enabled, due to quadratic (O(n^2)) processing in the smartquotes rule. The issue stems from repeatedly modifying strings with replaceAt(), which performs O(n) slicing and concatenation per quote character. This can cause excessive CPU consumption when parsing quote-heavy, user-supplied markdown and may let attackers degrade or disrupt service availability. Although typographer is disabled by default, many production apps enable it for smart typography, making the issue relevant. This issue has been fixed in version 1

    Veröffentlicht Aktualisiert
  2. CVE-2026-2327

    Mittel · CVSS 6.9EPSS 0,74%Keine Korrektur veröffentlicht

    CVE-2026-2327

    Versions of the package markdown-it from 13.0.0 and before 14.1.1 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the use of the regex /\*+$/ in the linkify function. An attacker can supply a long sequence of * characters followed by a non-matching character, which triggers excessive backtracking and may lead to a denial-of-service condition.

    Veröffentlicht Aktualisiert
  3. CVE-2025-7969

    Mittel · CVSS 6.9EPSS 0,25%Keine Korrektur veröffentlicht

    Markdown-it 14.1.0 - Cross-site scripting (XSS)

    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in markdown-it allows Cross-Site Scripting (XSS). This vulnerability is associated with program files lib/renderer.mjs. This issue affects markdown-it: 14.1.0. NOTE: the Supplier does not consider this issue to be a vulnerability.

    Veröffentlicht Aktualisiert
  4. CVE-2015-10005

    Niedrig · CVSS 3.5EPSS 0,99%Keine Korrektur veröffentlicht

    markdown-it html_re.js redos

    A vulnerability was found in markdown-it up to 2.x. It has been classified as problematic. Affected is an unknown function of the file lib/common/html_re.js. The manipulation leads to inefficient regular expression complexity. Upgrading to version 3.0.0 is able to address this issue. The name of the patch is 89c8620157d6e38f9872811620d25138fc9d1b0d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216852.

    Veröffentlicht Aktualisiert
  5. CVE-2022-21670

    Mittel · CVSS 5.3EPSS 2,28%Keine Korrektur veröffentlicht

    Uncontrolled Resource Consumption in markdown-it

    markdown-it is a Markdown parser. Prior to version 1.3.2, special patterns with length greater than 50 thousand characterss could slow down the parser significantly. Users should upgrade to version 12.3.2 to receive a patch. There are no known workarounds aside from upgrading.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →