p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in qtbase-opensource-src-gles

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für qtbase-opensource-src-gles: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 15

  1. CVE-2025-14575

    Niedrig · CVSS 1.8EPSS 0,09%Keine Korrektur veröffentlicht

    Uncontrolled Search Path Element in Qt Network OpenSSL TLS backend allows rogue CA certificate loading

    An Uncontrolled Search Path Element vulnerability in the OpenSSL TLS backend of Qt Network (qtbase) in Qt Qt Framework (Unix) allows a local attacker to load a rogue CA certificate as a trusted system authority via a crafted certificate file placed in the application's working directory.

    Veröffentlicht Aktualisiert
  2. CVE-2025-5991

    Niedrig · CVSS 2.1EPSS 0,14%Keine Korrektur veröffentlicht

    Use after free in QHttp2ProtocolHandler

    There is a "Use After Free" vulnerability in Qt's QHttp2ProtocolHandler in the QtNetwork module. This only affects HTTP/2 handling, HTTP handling is not affected by this at all. This happens due to a race condition between how QHttp2Stream uploads the body of a POST request and the simultaneous handling of HTTP error responses. This issue only affects Qt 6.9.0 and has been fixed for Qt 6.9.1.

    Veröffentlicht Aktualisiert
  3. CVE-2025-5455

    Hoch · CVSS 8.4EPSS 0,38%Keine Korrektur veröffentlicht

    Possible denial of service when passing malformed data in a URL to qDecodeDataUrl

    An issue was found in the private API function qDecodeDataUrl() in QtCore, which is used in QTextDocument and QNetworkReply, and, potentially, in user code. If the function was called with malformed data, for example, an URL that contained a "charset" parameter that lacked a value (such as "data:charset,"), and Qt was built with assertions enabled, then it would hit an assertion, resulting in a denial of service (abort). This impacts Qt up to 5.15.18, 6.0.0->6.5.8, 6.6.0->6.8.3 and 6.9.0. This has been fixed in 5.15.19, 6.5.9, 6.8.4 and 6.9.1.

    Veröffentlicht Aktualisiert
  4. CVE-2025-4211

    Hoch · CVSS 7.3EPSS 0,21%Keine Korrektur veröffentlicht

    Improper Link Resolution Before File Access in QFileSystemEngine on Windows

    Improper Link Resolution Before File Access ('Link Following') vulnerability in QFileSystemEngine in the Qt corelib module on Windows which potentially allows Symlink Attacks and the use of Malicious Files. Issue originates from CVE-2024-38081. The vulnerability arises from the use of the GetTempPath API, which can be exploited by attackers to manipulate temporary file paths, potentially leading to unauthorized access and privilege escalation. The affected public API in the Qt Framework is QDir::tempPath() and anything that uses it, such as QStandardPaths with TempLocation, QTemporaryDir, and QTemporaryFile. This issue affects all version of

    Veröffentlicht Aktualisiert
  5. CVE-2025-3512

    Mittel · CVSS 4.8EPSS 0,23%Keine Korrektur veröffentlicht

    Buffer overflow in QTextMarkdownImporter

    There is a Heap-based Buffer Overflow vulnerability in QTextMarkdownImporter. This requires an incorrectly formatted markdown file to be passed to QTextMarkdownImporter to trigger the overflow. This issue affects Qt from 6.8.0 to 6.8.4. Versions up to 6.6.0 are known to be unaffected, and the fix is in 6.8.4 and later.

    Veröffentlicht Aktualisiert
  6. CVE-2023-43114

    Mittel · CVSS 5.5EPSS 0,27%Keine Korrektur veröffentlicht

    CVE-2023-43114

    An issue was discovered in Qt before 5.15.16, 6.x before 6.2.10, and 6.3.x through 6.5.x before 6.5.3 on Windows. When using the GDI font engine, if a corrupted font is loaded via QFontDatabase::addApplicationFont{FromData], then it can cause the application to crash because of missing length checks.

    Veröffentlicht Aktualisiert
  7. CVE-2023-32762

    Mittel · CVSS 5.3EPSS 0,88%Keine Korrektur veröffentlicht

    CVE-2023-32762

    An issue was discovered in Qt before 5.15.14, 6.x before 6.2.9, and 6.3.x through 6.5.x before 6.5.1. Qt Network incorrectly parses the strict-transport-security (HSTS) header, allowing unencrypted connections to be established, even when explicitly prohibited by the server. This happens if the case used for this header does not exactly match.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →