p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in heimdal

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für heimdal: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 11

  1. CVE-2022-45142

    Hoch · CVSS 7.5EPSS 0,49%Korrektur verfügbar

    CVE-2022-45142

    The fix for CVE-2022-3437 included changing memcmp to be constant time and a workaround for a compiler bug by adding "!= 0" comparisons to the result of memcmp. When these patches were backported to the heimdal-7.7.1 and heimdal-7.8.0 branches (and possibly other branches) a logic inversion sneaked in causing the validation of message integrity codes in gssapi/arcfour to be inverted.

    • Auf 1.6~git20131207+dfsg-1ubuntu1.2+esm4 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2022-3437

    Mittel · CVSS 4.3EPSS 3,86%Korrektur verfügbar

    CVE-2022-3437

    A heap-based buffer overflow vulnerability was found in Samba within the GSSAPI unwrap_des() and unwrap_des3() routines of Heimdal. The DES and Triple-DES decryption routines in the Heimdal GSSAPI library allow a length-limited write buffer overflow on malloc() allocated memory when presented with a maliciously small packet. This flaw allows a remote user to send specially crafted malicious data to the application, possibly resulting in a denial of service (DoS) attack.

    • Auf 1.6~git20131207+dfsg-1ubuntu1.2+esm3 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2022-42898

    Hoch · CVSS 8.8EPSS 6,86%Korrektur verfügbar

    CVE-2022-42898

    PAC parsing in MIT Kerberos 5 (aka krb5) before 1.19.4 and 1.20.x before 1.20.1 has integer overflows that may lead to remote code execution (in KDC, kadmind, or a GSS or Kerberos application server) on 32-bit platforms (which have a resultant heap-based buffer overflow), and cause a denial of service on other platforms. This occurs in krb5_pac_parse in lib/krb5/krb/pac.c. Heimdal before 7.7.1 has "a similar bug."

    • Auf 1.6~git20131207+dfsg-1ubuntu1.2+esm3 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2022-41916

    Mittel · CVSS 5.9EPSS 1%Korrektur verfügbar

    Read one byte past a buffer when normalizing Unicode

    Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.

    • Auf 1.6~git20131207+dfsg-1ubuntu1.2+esm2 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2018-16860

    Hoch · CVSS 7.5EPSS 2,49%Korrektur verfügbar

    CVE-2018-16860

    A flaw was found in samba's Heimdal KDC implementation, versions 4.8.x up to, excluding 4.8.12, 4.9.x up to, excluding 4.9.8 and 4.10.x up to, excluding 4.10.3, when used in AD DC mode. A man in the middle attacker could use this flaw to intercept the request to the KDC and replace the user name (principal) in the request with any desired user name (principal) that exists in the KDC effectively obtaining a ticket for that principal.

    • Auf 1.6~git20131207+dfsg-1ubuntu1.2+esm1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →