p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in jruby · Seite 3

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für jruby: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 50

  1. CVE-2018-1000075

    Hoch · CVSS 7.5EPSS 4,74%Korrektur verfügbar

    CVE-2018-1000075

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caused by negative size vulnerability in ruby gem package tar header that can result in a negative size could cause an infinite loop.. This vulnerability appears to have been fixed in 2.7.6.

    • Auf 1.5.6-9+deb8u2build0.14.04.1~esm2 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2018-1000074

    Hoch · CVSS 7.8EPSS 2,88%Korrektur verfügbar

    CVE-2018-1000074

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.

    • Auf 1.5.6-9+deb8u2build0.14.04.1~esm2 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2018-1000073

    Hoch · CVSS 7.5EPSS 4,91%Keine Korrektur veröffentlicht

    CVE-2018-1000073

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.

    Veröffentlicht Aktualisiert
  4. CVE-2017-0903

    Kritisch · CVSS 9.8EPSS 15,85%Keine Korrektur veröffentlicht

    CVE-2017-0903

    RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability. YAML deserialization of gem specifications can bypass class white lists. Specially crafted serialized objects can possibly be used to escalate to remote code execution.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →