p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in moodle · Seite 13

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für moodle: 12. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 323

  1. CVE-2020-25630

    Hoch · CVSS 7.5EPSS 1,36%Keine Korrektur veröffentlicht

    CVE-2020-25630

    A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of service risk. This affects versions 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

    Veröffentlicht Aktualisiert
  2. CVE-2020-25631

    Mittel · CVSS 6.1EPSS 0,93%Keine Korrektur veröffentlicht

    CVE-2020-25631

    A vulnerability was found in Moodle 3.9 to 3.9.1, 3.8 to 3.8.4 and 3.7 to 3.7.7 where it was possible to include JavaScript in a book's chapter title, which was not escaped on the "Add new chapter" page. This is fixed in 3.9.2, 3.8.5 and 3.7.8.

    Veröffentlicht Aktualisiert
  3. CVE-2020-25700

    Mittel · CVSS 6.5EPSS 1,34%Keine Korrektur veröffentlicht

    CVE-2020-25700

    In moodle, some database module web services allowed students to add entries within groups they did not belong to. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.8.6, 3.7.9, 3.5.15, and 3.10.

    Veröffentlicht Aktualisiert
  4. CVE-2020-25701

    Mittel · CVSS 5.3EPSS 1,39%Keine Korrektur veröffentlicht

    CVE-2020-25701

    If the upload course tool in Moodle was used to delete an enrollment method which did not exist or was not already enabled, the tool would erroneously enable that enrollment method. This could lead to unintended users gaining access to the course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

    Veröffentlicht Aktualisiert
  5. CVE-2020-25698

    Hoch · CVSS 7.5EPSS 1,92%Keine Korrektur veröffentlicht

    CVE-2020-25698

    Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

    Veröffentlicht Aktualisiert
  6. CVE-2020-25699

    Hoch · CVSS 7.5EPSS 1,61%Keine Korrektur veröffentlicht

    CVE-2020-25699

    In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles within that course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

    Veröffentlicht Aktualisiert
  7. CVE-2020-10738

    Hoch · CVSS 7.5EPSS 3%Keine Korrektur veröffentlicht

    CVE-2020-10738

    A flaw was found in Moodle versions 3.8 before 3.8.3, 3.7 before 3.7.6, 3.6 before 3.6.10, 3.5 before 3.5.12 and earlier unsupported versions. It was possible to create a SCORM package in such a way that when added to a course, it could be interacted with via web services in order to achieve remote code execution.

    Veröffentlicht Aktualisiert
  8. CVE-2019-14880

    Mittel · CVSS 4.8EPSS 1,11%Keine Korrektur veröffentlicht

    CVE-2019-14880

    A vulnerability was found in Moodle versions 3.7 before 3.7.3, 3.6 before 3.6.7, 3.5 before 3.5.9 and earlier. OAuth 2 providers who do not verify users' email address changes require additional verification during sign-up to reduce the risk of account compromise.

    Veröffentlicht Aktualisiert
  9. CVE-2019-18210

    Mittel · CVSS 5.4EPSS 0,79%Keine Korrektur veröffentlicht

    CVE-2019-18210

    Persistent XSS in /course/modedit.php of Moodle through 3.7.2 allows authenticated users (Teacher and above) to inject JavaScript into the session of another user (e.g., enrolled student or site administrator) via the introeditor[text] parameter. NOTE: the discoverer and vendor disagree on whether Moodle customers have a reasonable expectation that anyone authenticated as a Teacher can be trusted with the ability to add arbitrary JavaScript (this ability is not documented on Moodle's Teacher_role page). Because the vendor has this expectation, they have stated "this report has been closed as a false positive, and not a bug."

    Veröffentlicht Aktualisiert
  10. CVE-2019-14879

    Mittel · CVSS 4.2EPSS 0,71%Keine Korrektur veröffentlicht

    CVE-2019-14879

    A vulnerability was found in Moodle versions 3.7.x before 3.7.3, 3.6.x before 3.6.7 and 3.5.x before 3.5.9. When a cohort role assignment was removed, the associated capabilities were not being revoked (where applicable).

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →