p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in moodle · Seite 12

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für moodle: 12. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 323

  1. CVE-2021-21809

    Hoch · CVSS 8.2EPSS 24,17%Öffentlicher ExploitKeine Korrektur veröffentlicht

    CVE-2021-21809

    A command execution vulnerability exists in the default legacy spellchecker plugin in Moodle 3.10. A specially crafted series of HTTP requests can lead to command execution. An attacker must have administrator privileges to exploit this vulnerabilities.

    Veröffentlicht Aktualisiert
  2. CVE-2019-14827

    Mittel · CVSS 6.1EPSS 0,67%Keine Korrektur veröffentlicht

    CVE-2019-14827

    A vulnerability was found in Moodle where javaScript injection was possible in some Mustache templates via recursive rendering from contexts. Mustache helper tags that were included in template contexts were not being escaped before that context was injected into another Mustache helper, which could result in script injection in some templates. This affects versions 3.7 to 3.7.1, 3.6 to 3.6.5, 3.5 to 3.5.7 and earlier unsupported versions.

    Veröffentlicht Aktualisiert
  3. CVE-2019-14831

    Mittel · CVSS 6.1EPSS 0,81%Keine Korrektur veröffentlicht

    CVE-2019-14831

    A vulnerability was found in Moodle 3.7 to 3.7.1, 3.6 to 3.6.5, 3.5 to 3.5.7 and earlier unsupported versions, where forum subscribe link contained an open redirect if forced subscription mode was enabled. If a forum's subscription mode was set to "forced subscription", the forum's subscribe link contained an open redirect.

    Veröffentlicht Aktualisiert
  4. CVE-2019-14830

    Mittel · CVSS 6.1EPSS 3,3%Keine Korrektur veröffentlicht

    CVE-2019-14830

    A vulnerability was found in Moodle 3.7 to 3.7.1, 3.6 to 3.6.5, 3.5 to 3.5.7 and earlier unsupported versions, where the mobile launch endpoint contained an open redirect in some circumstances, which could result in a user's mobile access token being exposed. (Note: This does not affect sites with a forced URL scheme configured, mobile service disabled, or where the mobile app login method is "via the app").

    Veröffentlicht Aktualisiert
  5. CVE-2019-14828

    Mittel · CVSS 4.3EPSS 0,7%Keine Korrektur veröffentlicht

    CVE-2019-14828

    A vulnerability was found in Moodle affecting 3.7 to 3.7.1, 3.6 to 3.6.5, 3.5 to 3.5.7 and earlier unsupported versions, where users with the capability to create courses were assigned as a teacher in those courses, regardless of whether they had the capability to be automatically assigned that role.

    Veröffentlicht Aktualisiert
  6. CVE-2021-20185

    Mittel · CVSS 5.3EPSS 1,39%Keine Korrektur veröffentlicht

    CVE-2021-20185

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that messaging did not impose a character limit when sending messages, which could result in client-side (browser) denial of service for users receiving very large messages.

    Veröffentlicht Aktualisiert
  7. CVE-2021-20184

    Mittel · CVSS 4.3EPSS 0,73%Keine Korrektur veröffentlicht

    CVE-2021-20184

    It was found in Moodle before version 3.10.1, 3.9.4 and 3.8.7 that a insufficient capability checks in some grade related web services meant students were able to view other students grades.

    Veröffentlicht Aktualisiert
  8. CVE-2021-20186

    Mittel · CVSS 5.4EPSS 0,76%Keine Korrektur veröffentlicht

    CVE-2021-20186

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that if the TeX notation filter was enabled, additional sanitizing of TeX content was required to prevent the risk of stored XSS.

    Veröffentlicht Aktualisiert
  9. CVE-2021-20187

    Hoch · CVSS 7.2EPSS 1,59%Keine Korrektur veröffentlicht

    CVE-2021-20187

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP scripts via a PHP include used during Shibboleth authentication.

    Veröffentlicht Aktualisiert
  10. CVE-2020-25629

    Hoch · CVSS 8.8EPSS 1,32%Keine Korrektur veröffentlicht

    CVE-2020-25629

    A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. This is fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →