p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in dnsmasq

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für dnsmasq: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 16

  1. CVE-2026-13002

    Mittel · CVSS 4.4EPSS 0,15%Keine Korrektur veröffentlicht

    Dnsmasq: infinite loop dos in dnssec nsec/nsec3 type bitmap parsing

    A flow has been identified into dnssec.c library, causing an infinite loop to dnsmasq service. An attacker who controls any DNSSEC-signed zone can hang the dnsmasq process with a single crafted response, killing all DNS resolution for its clients.

    Veröffentlicht Aktualisiert
  2. CVE-2026-12969

    Mittel · CVSS 5.3EPSS 0,26%Korrektur verfügbar

    Dnsmasq: dnsmasq: out-of-bounds read in find_soa() due to missing extrabytes validation

    An out-of-bounds read vulnerability exists in dnsmasq's find_soa() function in src/rfc1035.c. When parsing NS section records, extract_name() is called with extrabytes=0, failing to validate that 10 additional bytes exist for fixed-length DNS record fields. A remote attacker controlling a DNS zone can exploit this via a crafted NXDOMAIN response to cause a 10-byte heap out-of-bounds read, potentially accessing stale data from prior transactions.

    • Auf 2.90-0ubuntu0.18.04.1+esm4 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2026-12725

    Mittel · CVSS 5.9EPSS 0,53%Korrektur verfügbar

    Dnsmasq: dnsmasq: heap buffer overflow in log_query() when logging unsupported ds/dnskey replies

    A heap-based buffer overflow was found in dnsmasq. When DNSSEC validation and query logging are both enabled, logging of DS or DNSKEY replies containing unsupported algorithm or digest types can cause dnsmasq to write past the end of an internal logging buffer. A remote attacker able to supply such a DNS response may crash the dnsmasq process, resulting in denial of service.

    • Auf 2.90-0ubuntu0.18.04.1+esm4 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2026-5172

    Hoch · CVSS 7.3EPSS 2,68%Korrektur verfügbar

    CVE-2026-5172

    A buffer overflow in dnsmasq’s extract_addresses() function allows an attacker to trigger a heap out-of-bounds read and crash by exploiting a malformed DNS response, enabling extract_name() to advance the pointer past the record’s end.

    • Auf 2.90-0ubuntu0.18.04.1+esm3 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2026-2291

    Hoch · CVSS 7.3EPSS 0,61%Öffentlicher ExploitKorrektur verfügbar

    CVE-2026-2291

    dnsmasqs extract_name() function can be abused to cause a heap buffer overflow, allowing an attacker to inject false DNS cache entries, which could result in DNS lookups to redirect to an attacker-controlled IP address, or to cause a DoS.

    • Auf 2.90-0ubuntu0.18.04.1+esm3 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2020-37127

    Mittel · CVSS 6.9EPSS 0,21%Korrektur verfügbar

    dnsmasq-utils 2.79-1 - 'dhcp_release' Denial of Service

    Dnsmasq-utils 2.79-1 contains a buffer overflow vulnerability in the dhcp_release utility that allows attackers to cause a denial of service by supplying excessive input. Attackers can trigger a core dump and terminate the dhcp_release process by sending a crafted input string longer than 16 characters.

    • Auf 2.90-0ubuntu0.18.04.1+esm1 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2025-12200

    Mittel · CVSS 4.8Keine Korrektur veröffentlicht

    UBUNTU-CVE-2025-12200

    Rejected reason: ** REJECT ** DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: none. Reason: This candidate was withdrawn by its CNA. Further investigation showed that it was not a security issue. Notes: Based on the analysis by MITRE and review of community feedback, the reported conditions represent expected and intentional behavior within dnsmasq's documented design, rather than security vulnerabilities.

    Veröffentlicht Aktualisiert
  8. CVE-2025-12199

    Mittel · CVSS 4.8Keine Korrektur veröffentlicht

    UBUNTU-CVE-2025-12199

    Rejected reason: ** REJECT ** DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: none. Reason: This candidate was withdrawn by its CNA. Further investigation showed that it was not a security issue. Notes: Based on the analysis by MITRE and review of community feedback, the reported conditions represent expected and intentional behavior within dnsmasq's documented design, rather than security vulnerabilities.

    Veröffentlicht Aktualisiert
  9. CVE-2025-12198

    Hoch · CVSS 8.5Keine Korrektur veröffentlicht

    UBUNTU-CVE-2025-12198

    Rejected reason: ** REJECT ** DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: none. Reason: This candidate was withdrawn by its CNA. Further investigation showed that it was not a security issue. Notes: Based on the analysis by MITRE and review of community feedback, the reported conditions represent expected and intentional behavior within dnsmasq's documented design, rather than security vulnerabilities.

    Veröffentlicht Aktualisiert
  10. CVE-2023-50868

    Hoch · CVSS 7.5EPSS 74,3%Korrektur verfügbar

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Auf 2.90-0ubuntu0.18.04.1+esm1 aktualisieren
    Veröffentlicht Aktualisiert
  11. CVE-2023-50387

    Hoch · CVSS 7.5EPSS 99,99%Korrektur verfügbar

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Auf 2.90-0ubuntu0.18.04.1+esm1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →