ALPINE-CVE-2018-0732
ALPINE-CVE-2018-0732
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
During key agreement in a TLS handshake using a DH(E) based ciphersuite a malicious server can send a very large prime value to the client. This will cause the client to spend an unreasonably long period of time generating a key for this prime resulting in a hang until the client has finished. This could be exploited in a Denial Of Service attack. Fixed in OpenSSL 1.1.0i-dev (Affected 1.1.0-1.1.0h). Fixed in OpenSSL 1.0.2p-dev (Affected 1.0.2-1.0.2o).
CVSS 7.5 · Alta · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · network
Productos y versiones afectados
libressl Alpine:v3.10
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.4-r0
Actualiza a 2.7.4-r0
libressl Alpine:v3.11
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.4-r0
Actualiza a 2.7.4-r0
libressl Alpine:v3.12
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.4-r0
Actualiza a 2.7.4-r0
libressl Alpine:v3.13
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.4-r0
Actualiza a 2.7.4-r0
libressl Alpine:v3.7
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.6.5-r0
Actualiza a 2.6.5-r0
libressl Alpine:v3.8
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.4-r0
Actualiza a 2.7.4-r0
libressl Alpine:v3.9
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.4-r0
Actualiza a 2.7.4-r0
openssl Alpine:v3.3
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.0.2, < 1.0.2o-r1
Actualiza a 1.0.2o-r1
openssl Alpine:v3.4
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.0.2, < 1.0.2o-r1
Actualiza a 1.0.2o-r1
openssl Alpine:v3.5
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.0.2, < 1.0.2o-r1
Actualiza a 1.0.2o-r1
openssl Alpine:v3.6
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.0.2, < 1.0.2o-r1
Actualiza a 1.0.2o-r1
openssl Alpine:v3.7
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.0.2, < 1.0.2o-r1
Actualiza a 1.0.2o-r1
openssl Alpine:v3.8
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.0.2, < 1.0.2o-r1
Actualiza a 1.0.2o-r1