ALPINE-CVE-2018-0732
ALPINE-CVE-2018-0732
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
During key agreement in a TLS handshake using a DH(E) based ciphersuite a malicious server can send a very large prime value to the client. This will cause the client to spend an unreasonably long period of time generating a key for this prime resulting in a hang until the client has finished. This could be exploited in a Denial Of Service attack. Fixed in OpenSSL 1.1.0i-dev (Affected 1.1.0-1.1.0h). Fixed in OpenSSL 1.0.2p-dev (Affected 1.0.2-1.0.2o).
CVSS 7.5 · Hoch · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · network
Betroffene Produkte und Versionen
libressl Alpine:v3.10
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.4-r0
Auf 2.7.4-r0 aktualisieren
libressl Alpine:v3.11
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.4-r0
Auf 2.7.4-r0 aktualisieren
libressl Alpine:v3.12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.4-r0
Auf 2.7.4-r0 aktualisieren
libressl Alpine:v3.13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.4-r0
Auf 2.7.4-r0 aktualisieren
libressl Alpine:v3.7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.6.5-r0
Auf 2.6.5-r0 aktualisieren
libressl Alpine:v3.8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.4-r0
Auf 2.7.4-r0 aktualisieren
libressl Alpine:v3.9
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.4-r0
Auf 2.7.4-r0 aktualisieren
openssl Alpine:v3.3
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.0.2, < 1.0.2o-r1
Auf 1.0.2o-r1 aktualisieren
openssl Alpine:v3.4
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.0.2, < 1.0.2o-r1
Auf 1.0.2o-r1 aktualisieren
openssl Alpine:v3.5
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.0.2, < 1.0.2o-r1
Auf 1.0.2o-r1 aktualisieren
openssl Alpine:v3.6
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.0.2, < 1.0.2o-r1
Auf 1.0.2o-r1 aktualisieren
openssl Alpine:v3.7
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.0.2, < 1.0.2o-r1
Auf 1.0.2o-r1 aktualisieren
openssl Alpine:v3.8
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.0.2, < 1.0.2o-r1
Auf 1.0.2o-r1 aktualisieren