p PatchFirst

ALPINE-CVE-2019-1551

ALPINE-CVE-2019-1551

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

There is an overflow bug in the x64_64 Montgomery squaring procedure used in exponentiation with 512-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against 2-prime RSA1024, 3-prime RSA1536, and DSA1024 as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH512 are considered just feasible. However, for an attack the target would have to re-use the DH512 private key, which is not recommended anyway. Also applications directly using the low level API BN_mod_exp may be affected if they use BN_FLG_CONSTTIME. Fixed in OpenSSL 1.1.1e (Affected 1.1.1-1.1.1d). Fixed in OpenSSL 1.0.2u (Affected 1.0.2-1.0.2t).

CVSS 5.3 · Media · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · network

Productos y versiones afectados

  • openssl Alpine:v3.10

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r2

    Actualiza a 1.1.1d-r2

  • openssl Alpine:v3.11

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl Alpine:v3.12

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl Alpine:v3.13

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl Alpine:v3.14

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl Alpine:v3.15

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl Alpine:v3.16

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl Alpine:v3.17

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl Alpine:v3.18

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl Alpine:v3.19

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl Alpine:v3.20

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl Alpine:v3.21

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl Alpine:v3.22

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl Alpine:v3.23

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl Alpine:v3.24

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl Alpine:v3.8

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.0.2u-r0

    Actualiza a 1.0.2u-r0

  • openssl Alpine:v3.9

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r2

    Actualiza a 1.1.1d-r2

  • openssl3 Alpine:v3.15

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

  • openssl3 Alpine:v3.16

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.1.1d-r3

    Actualiza a 1.1.1d-r3

Fuentes originales

Comprueba tu servidor →