p PatchFirst

ALPINE-CVE-2019-1551

ALPINE-CVE-2019-1551

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

There is an overflow bug in the x64_64 Montgomery squaring procedure used in exponentiation with 512-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against 2-prime RSA1024, 3-prime RSA1536, and DSA1024 as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH512 are considered just feasible. However, for an attack the target would have to re-use the DH512 private key, which is not recommended anyway. Also applications directly using the low level API BN_mod_exp may be affected if they use BN_FLG_CONSTTIME. Fixed in OpenSSL 1.1.1e (Affected 1.1.1-1.1.1d). Fixed in OpenSSL 1.0.2u (Affected 1.0.2-1.0.2t).

CVSS 5.3 · Mittel · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · network

Betroffene Produkte und Versionen

  • openssl Alpine:v3.10

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r2

    Auf 1.1.1d-r2 aktualisieren

  • openssl Alpine:v3.11

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl Alpine:v3.12

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl Alpine:v3.13

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl Alpine:v3.14

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl Alpine:v3.15

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl Alpine:v3.16

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl Alpine:v3.17

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl Alpine:v3.18

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl Alpine:v3.19

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl Alpine:v3.20

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl Alpine:v3.21

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl Alpine:v3.22

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl Alpine:v3.23

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl Alpine:v3.24

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl Alpine:v3.8

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.0.2u-r0

    Auf 1.0.2u-r0 aktualisieren

  • openssl Alpine:v3.9

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.2, < 1.1.1d-r2

    Auf 1.1.1d-r2 aktualisieren

  • openssl3 Alpine:v3.15

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

  • openssl3 Alpine:v3.16

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.1.1d-r3

    Auf 1.1.1d-r3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →