ALPINE-CVE-2023-24807
ALPINE-CVE-2023-24807
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Undici is an HTTP/1.1 client for Node.js. Prior to version 5.19.1, the `Headers.set()` and `Headers.append()` methods are vulnerable to Regular Expression Denial of Service (ReDoS) attacks when untrusted values are passed into the functions. This is due to the inefficient regular expression used to normalize the values in the `headerValueNormalize()` utility function. This vulnerability was patched in v5.19.1. No known workarounds are available.
CVSS 7.5 · Alta · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
nodejs Alpine:v3.15
- Intervalos de versiones afectados
- ECOSYSTEM: < 16.19.1-r0
Actualiza a 16.19.1-r0
nodejs Alpine:v3.16
- Intervalos de versiones afectados
- ECOSYSTEM: < 16.19.1-r0
Actualiza a 16.19.1-r0
nodejs Alpine:v3.17
- Intervalos de versiones afectados
- ECOSYSTEM: < 18.14.1-r0
Actualiza a 18.14.1-r0
nodejs Alpine:v3.18
- Intervalos de versiones afectados
- ECOSYSTEM: < 18.14.1-r0
Actualiza a 18.14.1-r0
nodejs Alpine:v3.19
- Intervalos de versiones afectados
- ECOSYSTEM: < 18.14.1-r0
Actualiza a 18.14.1-r0
nodejs Alpine:v3.20
- Intervalos de versiones afectados
- ECOSYSTEM: < 18.14.1-r0
Actualiza a 18.14.1-r0
nodejs Alpine:v3.21
- Intervalos de versiones afectados
- ECOSYSTEM: < 18.14.1-r0
Actualiza a 18.14.1-r0
nodejs Alpine:v3.22
- Intervalos de versiones afectados
- ECOSYSTEM: < 18.14.1-r0
Actualiza a 18.14.1-r0
nodejs Alpine:v3.23
- Intervalos de versiones afectados
- ECOSYSTEM: < 18.14.1-r0
Actualiza a 18.14.1-r0
nodejs Alpine:v3.24
- Intervalos de versiones afectados
- ECOSYSTEM: < 18.14.1-r0
Actualiza a 18.14.1-r0