p PatchFirst

ALPINE-CVE-2023-24807

ALPINE-CVE-2023-24807

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Undici is an HTTP/1.1 client for Node.js. Prior to version 5.19.1, the `Headers.set()` and `Headers.append()` methods are vulnerable to Regular Expression Denial of Service (ReDoS) attacks when untrusted values are passed into the functions. This is due to the inefficient regular expression used to normalize the values in the `headerValueNormalize()` utility function. This vulnerability was patched in v5.19.1. No known workarounds are available.

CVSS 7.5 · Hoch · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • nodejs Alpine:v3.15

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 16.19.1-r0

    Auf 16.19.1-r0 aktualisieren

  • nodejs Alpine:v3.16

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 16.19.1-r0

    Auf 16.19.1-r0 aktualisieren

  • nodejs Alpine:v3.17

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 18.14.1-r0

    Auf 18.14.1-r0 aktualisieren

  • nodejs Alpine:v3.18

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 18.14.1-r0

    Auf 18.14.1-r0 aktualisieren

  • nodejs Alpine:v3.19

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 18.14.1-r0

    Auf 18.14.1-r0 aktualisieren

  • nodejs Alpine:v3.20

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 18.14.1-r0

    Auf 18.14.1-r0 aktualisieren

  • nodejs Alpine:v3.21

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 18.14.1-r0

    Auf 18.14.1-r0 aktualisieren

  • nodejs Alpine:v3.22

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 18.14.1-r0

    Auf 18.14.1-r0 aktualisieren

  • nodejs Alpine:v3.23

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 18.14.1-r0

    Auf 18.14.1-r0 aktualisieren

  • nodejs Alpine:v3.24

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 18.14.1-r0

    Auf 18.14.1-r0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →