p PatchFirst

ALPINE-CVE-2026-27820

ALPINE-CVE-2026-27820

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.

CVSS 9.8 · Crítica · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • ruby Alpine:v3.21

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.3.13-r0

    Actualiza a 3.3.13-r0

  • ruby Alpine:v3.22

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.4.9-r0

    Actualiza a 3.4.9-r0

  • ruby Alpine:v3.23

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.4.9-r0

    Actualiza a 3.4.9-r0

  • ruby Alpine:v3.24

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.4.9-r0

    Actualiza a 3.4.9-r0

Fuentes originales

Comprueba tu servidor →