p PatchFirst

ALPINE-CVE-2026-27820

ALPINE-CVE-2026-27820

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.

CVSS 9.8 · Kritisch · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • ruby Alpine:v3.21

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.3.13-r0

    Auf 3.3.13-r0 aktualisieren

  • ruby Alpine:v3.22

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.4.9-r0

    Auf 3.4.9-r0 aktualisieren

  • ruby Alpine:v3.23

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.4.9-r0

    Auf 3.4.9-r0 aktualisieren

  • ruby Alpine:v3.24

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.4.9-r0

    Auf 3.4.9-r0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →