p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de lighttpd

Vulnerabilidades publicadas para lighttpd en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 4

  1. ALPINE-CVE-2025-8671

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2025-8671

    A mismatch caused by client-triggered server-sent stream resets between HTTP/2 specifications and the internal architectures of some HTTP/2 implementations may result in excessive server resource consumption leading to denial-of-service (DoS). By opening streams and then rapidly triggering the server to reset them—using malformed frames or flow control errors—an attacker can exploit incorrect stream accounting. Streams reset by the server are considered closed at the protocol level, even though backend processing continues. This allows a client to cause the server to handle an unbounded number of concurrent streams on a single connection. Th

    • Actualiza a 0-r0
    Publicación Actualización
  2. ALPINE-CVE-2024-3094

    Crítica · CVSS 10Corrección disponible

    ALPINE-CVE-2024-3094

    Malicious code was discovered in the upstream tarballs of xz, starting with version 5.6.0. Through a series of complex obfuscations, the liblzma build process extracts a prebuilt object file from a disguised test file existing in the source code, which is then used to modify specific functions in the liblzma code. This results in a modified liblzma library that can be used by any software linked against this library, intercepting and modifying the data interaction with this library.

    • Actualiza a 1.4.76-r0
    Publicación Actualización
  3. ALPINE-CVE-2022-41556

    Alta · CVSS 7.5Corrección disponible

    ALPINE-CVE-2022-41556

    A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.

    • Actualiza a 1.4.67-r0
    Publicación Actualización
  4. ALPINE-CVE-2022-22707

    Media · CVSS 5.9Corrección disponible

    ALPINE-CVE-2022-22707

    In lighttpd 1.4.46 through 1.4.63, the mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow (4 bytes representing -1), as demonstrated by remote denial of service (daemon crash) in a non-default configuration. The non-default configuration requires handling of the Forwarded header in a somewhat unusual manner. Also, a 32-bit system is much more likely to be affected than a 64-bit system.

    • Actualiza a 1.4.64-r0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →