CVE-2018-1000888
CVE-2018-1000888
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
PEAR Archive_Tar version 1.4.3 and earlier contains a CWE-502, CWE-915 vulnerability in the Archive_Tar class. There are several file operations with `$v_header['filename']` as parameter (such as file_exists, is_file, is_dir, etc). When extract is called without a specific prefix path, we can trigger unserialization by crafting a tar file with `phar://[path_to_malicious_phar_file]` as path. Object injection can be used to trigger destruct in the loaded PHP classes, e.g. the Archive_Tar class itself. With Archive_Tar object injection, arbitrary file deletion can occur because `@unlink($this->_temp_tarname)` is called. If another class with useful gadget is loaded, it may possible to cause remote code execution that can result in files being deleted or possibly modified. This vulnerability appears to have been fixed in 1.4.4.
CVSS 8.8 · Alta · EPSS 19,1% · Código de explotación público · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
n/a
- Versiones
- n/a: Afectada
Sin corrección publicada
php-pear Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:1.10.6+submodules+notgz-1.1
Actualiza a 1:1.10.6+submodules+notgz-1.1
php-pear Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:1.10.6+submodules+notgz-1.1
Actualiza a 1:1.10.6+submodules+notgz-1.1
php-pear Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:1.10.6+submodules+notgz-1.1
Actualiza a 1:1.10.6+submodules+notgz-1.1
pear/archive_tar Packagist
- Versiones
- 1.3.11
- 1.3.12
- 1.3.13
- 1.3.14
- 1.3.15
- 1.3.16
- 1.4.0
- 1.4.1
- 1.4.2
- 1.4.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.4.4
Actualiza a 1.4.4
php-pear Ubuntu:16.04:LTS
- Versiones
- 1:1.10.1+submodules+notgz-4
- 1:1.10.1+submodules+notgz-6
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:1.10.1+submodules+notgz-6ubuntu0.1
Actualiza a 1:1.10.1+submodules+notgz-6ubuntu0.1
php-pear Ubuntu:18.04:LTS
- Versiones
- 1:1.10.5+submodules+notgz-1
- 1:1.10.5+submodules+notgz-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:1.10.5+submodules+notgz-1ubuntu1.18.04.1
Actualiza a 1:1.10.5+submodules+notgz-1ubuntu1.18.04.1
Fuentes originales
- https://lists.debian.org/debian-lts-announce/2019/02/msg00020.html
- https://usn.ubuntu.com/3857-1/
- https://www.debian.org/security/2019/dsa-4378
- https://www.exploit-db.com/exploits/46108/
- https://pear.php.net/package/Archive_Tar/download/
- https://cdn2.hubspot.net/hubfs/3853213/us-18-Thomas-It%27s-A-PHP-Unserialization-Vulnerability-Jim-But-Not-As-We-....pdf
- https://blog.ripstech.com/2018/new-php-exploitation-technique/
- https://pear.php.net/bugs/bug.php?id=23782
- https://security.gentoo.org/glsa/202006-14
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000888