p PatchFirst

CVE-2018-1000888

CVE-2018-1000888

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

PEAR Archive_Tar version 1.4.3 and earlier contains a CWE-502, CWE-915 vulnerability in the Archive_Tar class. There are several file operations with `$v_header['filename']` as parameter (such as file_exists, is_file, is_dir, etc). When extract is called without a specific prefix path, we can trigger unserialization by crafting a tar file with `phar://[path_to_malicious_phar_file]` as path. Object injection can be used to trigger destruct in the loaded PHP classes, e.g. the Archive_Tar class itself. With Archive_Tar object injection, arbitrary file deletion can occur because `@unlink($this->_temp_tarname)` is called. If another class with useful gadget is loaded, it may possible to cause remote code execution that can result in files being deleted or possibly modified. This vulnerability appears to have been fixed in 1.4.4.

CVSS 8.8 · Hoch · EPSS 19,1% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · php

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • php-pear Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:1.10.6+submodules+notgz-1.1

    Auf 1:1.10.6+submodules+notgz-1.1 aktualisieren

  • php-pear Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:1.10.6+submodules+notgz-1.1

    Auf 1:1.10.6+submodules+notgz-1.1 aktualisieren

  • php-pear Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:1.10.6+submodules+notgz-1.1

    Auf 1:1.10.6+submodules+notgz-1.1 aktualisieren

  • pear/archive_tar Packagist

    Softwareversionen
    • 1.3.11
    • 1.3.12
    • 1.3.13
    • 1.3.14
    • 1.3.15
    • 1.3.16
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.4.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.4.4

    Auf 1.4.4 aktualisieren

  • php-pear Ubuntu:16.04:LTS

    Softwareversionen
    • 1:1.10.1+submodules+notgz-4
    • 1:1.10.1+submodules+notgz-6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:1.10.1+submodules+notgz-6ubuntu0.1

    Auf 1:1.10.1+submodules+notgz-6ubuntu0.1 aktualisieren

  • php-pear Ubuntu:18.04:LTS

    Softwareversionen
    • 1:1.10.5+submodules+notgz-1
    • 1:1.10.5+submodules+notgz-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:1.10.5+submodules+notgz-1ubuntu1.18.04.1

    Auf 1:1.10.5+submodules+notgz-1ubuntu1.18.04.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →