p PatchFirst

CVE-2018-8007

CVE-2018-8007

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Apache CouchDB administrative users can configure the database server via HTTP(S). Due to insufficient validation of administrator-supplied configuration settings via the HTTP API, it is possible for a CouchDB administrator user to escalate their privileges to that of the operating system's user that CouchDB runs under, by bypassing the blacklist of configuration settings that are not allowed to be modified via the HTTP API. This privilege escalation effectively allows an existing CouchDB admin user to gain arbitrary remote code execution, bypassing already disclosed CVE-2017-12636. Mitigation: All users should upgrade to CouchDB releases 1.7.2 or 2.1.2.

CVSS 7.2 · Alta · EPSS 12,2%

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • apache couchdb

    Versiones
    • < 1.7.2: Afectada
    • 2.0.0 to 2.1.1: Afectada

    Sin corrección publicada

  • couchdb Ubuntu:16.04:LTS

    Versiones
    • 1.6.0-0ubuntu7
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →