p PatchFirst

CVE-2018-8007

CVE-2018-8007

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Apache CouchDB administrative users can configure the database server via HTTP(S). Due to insufficient validation of administrator-supplied configuration settings via the HTTP API, it is possible for a CouchDB administrator user to escalate their privileges to that of the operating system's user that CouchDB runs under, by bypassing the blacklist of configuration settings that are not allowed to be modified via the HTTP API. This privilege escalation effectively allows an existing CouchDB admin user to gain arbitrary remote code execution, bypassing already disclosed CVE-2017-12636. Mitigation: All users should upgrade to CouchDB releases 1.7.2 or 2.1.2.

CVSS 7.2 · Élevée · EPSS 12,2%

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • apache couchdb

    Versions du logiciel
    • < 1.7.2: Concernée
    • 2.0.0 to 2.1.1: Concernée

    Aucun correctif publié

  • couchdb Ubuntu:16.04:LTS

    Versions du logiciel
    • 1.6.0-0ubuntu7
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →