CVE-2019-5436
CVE-2019-5436
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
A heap buffer overflow in the TFTP receiving code allows for DoS or arbitrary code execution in libcurl versions 7.19.4 through 7.64.1.
CVSS 7.8 · Alta · EPSS 49,7% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
curl
- Versiones
- Fixed in 7.65.0: Afectada
Sin corrección publicada
curl Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.64.0-4
Actualiza a 7.64.0-4
curl Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.64.0-4
Actualiza a 7.64.0-4
curl Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.64.0-4
Actualiza a 7.64.0-4
curl Ubuntu:Pro:14.04:LTS
- Versiones
- 7.32.0-1ubuntu1
- 7.33.0-1ubuntu1
- 7.34.0-1ubuntu1
- 7.35.0-1ubuntu1
- 7.35.0-1ubuntu2
- 7.35.0-1ubuntu2.1
- 7.35.0-1ubuntu2.2
- 7.35.0-1ubuntu2.3
- 7.35.0-1ubuntu2.5
- 7.35.0-1ubuntu2.6
- 7.35.0-1ubuntu2.7
- 7.35.0-1ubuntu2.8
- 7.35.0-1ubuntu2.9
- 7.35.0-1ubuntu2.10
- 7.35.0-1ubuntu2.11
- 7.35.0-1ubuntu2.12
- 7.35.0-1ubuntu2.13
- 7.35.0-1ubuntu2.14
- 7.35.0-1ubuntu2.15
- 7.35.0-1ubuntu2.16
- 7.35.0-1ubuntu2.17
- 7.35.0-1ubuntu2.19
- 7.35.0-1ubuntu2.20
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.35.0-1ubuntu2.20+esm2
Actualiza a 7.35.0-1ubuntu2.20+esm2
curl Ubuntu:16.04:LTS
- Versiones
- 7.43.0-1ubuntu2
- 7.45.0-1ubuntu1
- 7.46.0-1ubuntu1
- 7.47.0-1ubuntu1
- 7.47.0-1ubuntu2
- 7.47.0-1ubuntu2.1
- 7.47.0-1ubuntu2.2
- 7.47.0-1ubuntu2.3
- 7.47.0-1ubuntu2.4
- 7.47.0-1ubuntu2.5
- 7.47.0-1ubuntu2.6
- 7.47.0-1ubuntu2.7
- 7.47.0-1ubuntu2.8
- 7.47.0-1ubuntu2.9
- 7.47.0-1ubuntu2.11
- 7.47.0-1ubuntu2.12
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.47.0-1ubuntu2.13
Actualiza a 7.47.0-1ubuntu2.13
curl Ubuntu:18.04:LTS
- Versiones
- 7.55.1-1ubuntu2
- 7.55.1-1ubuntu2.1
- 7.57.0-1ubuntu1
- 7.58.0-2ubuntu1
- 7.58.0-2ubuntu2
- 7.58.0-2ubuntu3
- 7.58.0-2ubuntu3.1
- 7.58.0-2ubuntu3.2
- 7.58.0-2ubuntu3.3
- 7.58.0-2ubuntu3.5
- 7.58.0-2ubuntu3.6
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.58.0-2ubuntu3.7
Actualiza a 7.58.0-2ubuntu3.7
Fuentes originales
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00017.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SMG3V4VTX2SE3EW3HQTN3DDLQBTORQC2/
- http://www.openwall.com/lists/oss-security/2019/09/11/6
- https://www.debian.org/security/2020/dsa-4633
- https://seclists.org/bugtraq/2020/Feb/36
- https://security.gentoo.org/glsa/202003-29
- https://www.oracle.com/security-alerts/cpuapr2020.html
- https://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html
- https://www.oracle.com/security-alerts/cpuoct2020.html
- https://security.netapp.com/advisory/ntap-20190606-0004/
- https://curl.haxx.se/docs/CVE-2019-5436.html
- https://support.f5.com/csp/article/K55133295
- https://support.f5.com/csp/article/K55133295?utm_source=f5support&%3Butm_medium=RSS
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-5436