p PatchFirst

CVE-2019-5436

CVE-2019-5436

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A heap buffer overflow in the TFTP receiving code allows for DoS or arbitrary code execution in libcurl versions 7.19.4 through 7.64.1.

CVSS 7.8 · Hoch · EPSS 49,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • curl

    Softwareversionen
    • Fixed in 7.65.0: Betroffen

    Keine Korrektur veröffentlicht

  • curl Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.64.0-4

    Auf 7.64.0-4 aktualisieren

  • curl Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.64.0-4

    Auf 7.64.0-4 aktualisieren

  • curl Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.64.0-4

    Auf 7.64.0-4 aktualisieren

  • curl Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 7.32.0-1ubuntu1
    • 7.33.0-1ubuntu1
    • 7.34.0-1ubuntu1
    • 7.35.0-1ubuntu1
    • 7.35.0-1ubuntu2
    • 7.35.0-1ubuntu2.1
    • 7.35.0-1ubuntu2.2
    • 7.35.0-1ubuntu2.3
    • 7.35.0-1ubuntu2.5
    • 7.35.0-1ubuntu2.6
    • 7.35.0-1ubuntu2.7
    • 7.35.0-1ubuntu2.8
    • 7.35.0-1ubuntu2.9
    • 7.35.0-1ubuntu2.10
    • 7.35.0-1ubuntu2.11
    • 7.35.0-1ubuntu2.12
    • 7.35.0-1ubuntu2.13
    • 7.35.0-1ubuntu2.14
    • 7.35.0-1ubuntu2.15
    • 7.35.0-1ubuntu2.16
    • 7.35.0-1ubuntu2.17
    • 7.35.0-1ubuntu2.19
    • 7.35.0-1ubuntu2.20
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.35.0-1ubuntu2.20+esm2

    Auf 7.35.0-1ubuntu2.20+esm2 aktualisieren

  • curl Ubuntu:16.04:LTS

    Softwareversionen
    • 7.43.0-1ubuntu2
    • 7.45.0-1ubuntu1
    • 7.46.0-1ubuntu1
    • 7.47.0-1ubuntu1
    • 7.47.0-1ubuntu2
    • 7.47.0-1ubuntu2.1
    • 7.47.0-1ubuntu2.2
    • 7.47.0-1ubuntu2.3
    • 7.47.0-1ubuntu2.4
    • 7.47.0-1ubuntu2.5
    • 7.47.0-1ubuntu2.6
    • 7.47.0-1ubuntu2.7
    • 7.47.0-1ubuntu2.8
    • 7.47.0-1ubuntu2.9
    • 7.47.0-1ubuntu2.11
    • 7.47.0-1ubuntu2.12
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.47.0-1ubuntu2.13

    Auf 7.47.0-1ubuntu2.13 aktualisieren

  • curl Ubuntu:18.04:LTS

    Softwareversionen
    • 7.55.1-1ubuntu2
    • 7.55.1-1ubuntu2.1
    • 7.57.0-1ubuntu1
    • 7.58.0-2ubuntu1
    • 7.58.0-2ubuntu2
    • 7.58.0-2ubuntu3
    • 7.58.0-2ubuntu3.1
    • 7.58.0-2ubuntu3.2
    • 7.58.0-2ubuntu3.3
    • 7.58.0-2ubuntu3.5
    • 7.58.0-2ubuntu3.6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.58.0-2ubuntu3.7

    Auf 7.58.0-2ubuntu3.7 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →