CVE-2020-15098
CVE-2020-15098 · Missing Required Cryptographic Step Leading to Sensitive Information Disclosure in TYPO3 CMS
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
In TYPO3 CMS greater than or equal to 9.0.0 and less than 9.5.20, and greater than or equal to 10.0.0 and less than 10.4.6, it has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. This allows to inject arbitrary data having a valid cryptographic message authentication code (HMAC-SHA1) and can lead to various attack chains including potential privilege escalation, insecure deserialization & remote code execution. The overall severity of this vulnerability is high based on mentioned attack chains and the requirement of having a valid backend user session (authenticated). This has been patched in versions 9.5.20 and 10.4.6.
CVSS 8.8 · Alta · EPSS 2,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
typo3 cms
- Versiones
- >= 9.0.0, < 9.5.20: Afectada
- >= 10.0.0, 10.4.6: Afectada
Sin corrección publicada
typo3/cms-core Packagist
- Versiones
- v9.0.0
- v9.1.0
- v9.2.0
- v9.2.1
- v9.3.0
- v9.3.1
- v9.3.2
- v9.3.3
- v9.4.0
- v9.5.0
- v9.5.1
- v9.5.10
- v9.5.11
- v9.5.12
- v9.5.13
- v9.5.14
- v9.5.15
- v9.5.16
- v9.5.17
- v9.5.18
- v9.5.19
- v9.5.2
- v9.5.3
- v9.5.4
- v9.5.5
- v9.5.6
- v9.5.7
- v9.5.8
- v9.5.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 9.0.0, < 9.5.20
Actualiza a 9.5.20
typo3/cms-core Packagist
- Versiones
- v10.0.0
- v10.1.0
- v10.2.0
- v10.2.1
- v10.2.2
- v10.3.0
- v10.4.0
- v10.4.1
- v10.4.2
- v10.4.3
- v10.4.4
- v10.4.5
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 10.0.0, < 10.4.6
Actualiza a 10.4.6
typo3/cms Packagist
- Versiones
- v10.0.0
- v10.1.0
- v10.2.0
- v10.2.1
- v10.2.2
- v10.3.0
- v10.4.0
- v10.4.1
- v10.4.2
- v10.4.3
- v10.4.4
- v10.4.5
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 10.0.0, < 10.4.6
Actualiza a 10.4.6
typo3/cms Packagist
- Versiones
- v9.0.0
- v9.1.0
- v9.2.0
- v9.2.1
- v9.3.0
- v9.3.1
- v9.3.2
- v9.3.3
- v9.4.0
- v9.5.0
- v9.5.1
- v9.5.10
- v9.5.11
- v9.5.12
- v9.5.13
- v9.5.14
- v9.5.15
- v9.5.16
- v9.5.17
- v9.5.18
- v9.5.19
- v9.5.2
- v9.5.3
- v9.5.4
- v9.5.5
- v9.5.6
- v9.5.7
- v9.5.8
- v9.5.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 9.0.0, < 9.5.20
Actualiza a 9.5.20
Fuentes originales
- https://github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-m5vr-3m74-jwxp
- https://typo3.org/security/advisory/typo3-core-sa-2016-013
- https://typo3.org/security/advisory/typo3-core-sa-2020-008
- https://github.com/TYPO3/TYPO3.CMS/commit/85d3e70dff35a99ef53f4b561114acfa9e5c47e1
- https://nvd.nist.gov/vuln/detail/CVE-2020-15098