CVE-2020-15098
CVE-2020-15098 · Missing Required Cryptographic Step Leading to Sensitive Information Disclosure in TYPO3 CMS
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
In TYPO3 CMS greater than or equal to 9.0.0 and less than 9.5.20, and greater than or equal to 10.0.0 and less than 10.4.6, it has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. This allows to inject arbitrary data having a valid cryptographic message authentication code (HMAC-SHA1) and can lead to various attack chains including potential privilege escalation, insecure deserialization & remote code execution. The overall severity of this vulnerability is high based on mentioned attack chains and the requirement of having a valid backend user session (authenticated). This has been patched in versions 9.5.20 and 10.4.6.
CVSS 8.8 · Élevée · EPSS 2,2% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: php
Produits et versions concernés
typo3 cms
- Versions du logiciel
- >= 9.0.0, < 9.5.20: Concernée
- >= 10.0.0, 10.4.6: Concernée
Aucun correctif publié
typo3/cms-core Packagist
- Versions du logiciel
- v9.0.0
- v9.1.0
- v9.2.0
- v9.2.1
- v9.3.0
- v9.3.1
- v9.3.2
- v9.3.3
- v9.4.0
- v9.5.0
- v9.5.1
- v9.5.10
- v9.5.11
- v9.5.12
- v9.5.13
- v9.5.14
- v9.5.15
- v9.5.16
- v9.5.17
- v9.5.18
- v9.5.19
- v9.5.2
- v9.5.3
- v9.5.4
- v9.5.5
- v9.5.6
- v9.5.7
- v9.5.8
- v9.5.9
- Plages de versions concernées
- ECOSYSTEM: ≥ 9.0.0, < 9.5.20
Mettez à jour vers 9.5.20
typo3/cms-core Packagist
- Versions du logiciel
- v10.0.0
- v10.1.0
- v10.2.0
- v10.2.1
- v10.2.2
- v10.3.0
- v10.4.0
- v10.4.1
- v10.4.2
- v10.4.3
- v10.4.4
- v10.4.5
- Plages de versions concernées
- ECOSYSTEM: ≥ 10.0.0, < 10.4.6
Mettez à jour vers 10.4.6
typo3/cms Packagist
- Versions du logiciel
- v10.0.0
- v10.1.0
- v10.2.0
- v10.2.1
- v10.2.2
- v10.3.0
- v10.4.0
- v10.4.1
- v10.4.2
- v10.4.3
- v10.4.4
- v10.4.5
- Plages de versions concernées
- ECOSYSTEM: ≥ 10.0.0, < 10.4.6
Mettez à jour vers 10.4.6
typo3/cms Packagist
- Versions du logiciel
- v9.0.0
- v9.1.0
- v9.2.0
- v9.2.1
- v9.3.0
- v9.3.1
- v9.3.2
- v9.3.3
- v9.4.0
- v9.5.0
- v9.5.1
- v9.5.10
- v9.5.11
- v9.5.12
- v9.5.13
- v9.5.14
- v9.5.15
- v9.5.16
- v9.5.17
- v9.5.18
- v9.5.19
- v9.5.2
- v9.5.3
- v9.5.4
- v9.5.5
- v9.5.6
- v9.5.7
- v9.5.8
- v9.5.9
- Plages de versions concernées
- ECOSYSTEM: ≥ 9.0.0, < 9.5.20
Mettez à jour vers 9.5.20
Sources originales
- https://github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-m5vr-3m74-jwxp
- https://typo3.org/security/advisory/typo3-core-sa-2016-013
- https://typo3.org/security/advisory/typo3-core-sa-2020-008
- https://github.com/TYPO3/TYPO3.CMS/commit/85d3e70dff35a99ef53f4b561114acfa9e5c47e1
- https://nvd.nist.gov/vuln/detail/CVE-2020-15098